Okay, guys, this is really weird. I don't really know why this happened, or how, so I'm just going to tell you everything I did and maybe you can figure it out for me.

I was reading an article at Astalavista on how to delete your Index.dat file. Having tried a few methods before, and being unsuccessful, I was naturally interested in finding a method that worked.

I opened AutoExec.bat in NotePad and placed these lines in it before the last one:

deltree /Y c:\windows\history\
deltree /Y c:\windows\cookies\
deltree /Y c:\windows\tempor~1\

Later, I restarted. When I clicked OK to Restart (I'm positive the radio button next to Restart was filled) I got the screen saying, "Windows is shutting down." And it froze there. Having no other option, I shut my machine off by the switch and turned it back on. Having then selected DOS from my Linux dual-boot screen, text ran up saying what files were being deleted, such as my cookies. The screen stayed up C:\Windows\tempor~1\content.ie5 for a very long time. (I'm using IE 6, by the way...) I just sat and looked at the screen waiting for it to do something. I was pretty sure it hadn't locked up, because some of the other files took a bit to delete, and my computer was making a whole bunch of sounds. Finally, after it was done, it booted into Windows 98 normally. I checked my index.dat file, and no longer were the URLs and machine language there, but rather content from a Web site I had read about a week before. It was in clear, complete paragraphs. As for the image files on the site, they were shown as <.img src="filename.ext"> At the end of the document, a word was cut off, almost as if there were a character limit. (Is there?) I restarted again, and this time it went smoothly, like a normal restart should. No lock-up, no unusually long wait. When I checked index.dat again, it was all gone. No paragraphs of text from that site I read, no URLs, no machine language. All that was in the file was something along the lines of this: Client UrlCache MMF Ver 5.2. Having felt somewhat like an idiot for deleting the evidence of this screwed up occurance, I decided not to post asking about it.... Until...

Okay, so I restarted one last time and went to bed. Next day (today), I come home from school, view a few sites, and check if the file would still work as it always used to, and what do I find? Reminants of that article I had read. It was no longer in full, complete paragraphs, but now in garbled up word fragments. I took a screen grab and attached it to this post.

The site with the article I read is right here:


Isn't that weird? Can anyone explain how that might have happened? Sorry for the long-windedness, I just wanted to be clear. I'm not making any of this up.