FreeBSD problems - Page 2
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: FreeBSD problems

  1. #11
    Senior Member
    Join Date
    Nov 2001
    Posts
    108
    Blah!
    I finally got it working!
    hehehe
    I changed /dev/mouse to /dev/sysmouse
    and added a few more stuff.

    Now I've got more problems:
    Can't get glib libaries to link with programs.
    I've got gtk 2.4.10 installed

    checking for gnome-config... no
    checking for Gnome compile flags... gnomeui: not found
    Gnome not found, building without it.
    checking for glib-config... no
    checking for GLIB - version >= 1.2.5... no
    *** The glib-config script installed by GLIB could not be found
    *** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
    *** your path, or set the GLIB_CONFIG environment variable to the
    *** full path to glib-config.
    configure: error:
    *** GLib is required to build Gaim; please make sure you have the GLib
    *** development headers installed. The latest version of GLib is
    *** always available at http://www.gtk.org/.



    /etc/resolv.conf that has my nameservers in it keeps cleaning itself out every few minutes so i have to manually add my isp nameservers in it
    Why isn't is staying permanent
    Speak softly and carry a big stick; you will go far. - Theodore Roosevelt
    Share on Google+

  2. #12
    Junior Member
    Join Date
    Jan 2002
    Posts
    25
    This is for linux systems, maybe it can be
    adapted for freebsd.

    1. Add "usepeerdns" to
    /etc/ppp/options
    2. modify the scripts
    /etc/ppp/ip-up and
    /etc/ppp/ip-down
    as follows
    ip-up


    This sample code shows you one way to modify your setup to allow automatic
    configuration of your resolv.conf for peer supplied DNS addresses when
    using the usepeerdns option.

    In my case I just added this to my /etc/ppp/ip-up.local script. You may
    need to create an executable script if one does not exist.

    You will also need to add the following to your ip-up.local and ip-down.local scripts:-

    Please add to your ip-up.local script:-

    if [ -n "$USEPEERDNS" -a -f /etc/ppp/resolv.conf ]; then
    rm -f /etc/ppp/resolv.prev
    if [ -f /etc/resolv.conf ]; then
    cp /etc/resolv.conf /etc/ppp/resolv.prev
    grep search /etc/ppp/resolv.prev > /etc/resolv.conf
    grep nameserver /etc/ppp/resolv.prev >> /etc/resolv.conf
    cat /etc/ppp/resolv.conf >> /etc/resolv.conf
    else
    cp /etc/ppp/resolv.conf /etc
    fi
    chmod 644 /etc/resolv.conf
    fi


    Please add to your ip-up.local script to restore the original state:-
    if [ -n "$USEPEERDNS" -a -f /etc/ppp/resolv.conf ]; then
    if [ -f /etc/ppp/resolv.prev ]; then
    cp -f /etc/ppp/resolv.prev /etc/resolv.conf
    else
    rm -f /etc/resolv.conf
    fi
    chmod 644 /etc/resolv.conf
    fi
    --
    \"UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity.\"
    Dennis Ritchie.
    Share on Google+

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •