First of all, thanks to all those guys who replied to my first post.
Thanks to you guys the install went off smoothly. But there's still a problem. The bloody thing won't boot! I'm still able to boot WinXP Pro, but OpenBSD refuses to boot up. I tried a couple of things to get it to work. Here they are in order:
First, my partition structure
1. Windows Fat32 Primary 10gb
2. Windows Fat32 Extended 5 GB
3. The remaining 4 GB is divided into a 514mb swap (partition no. 4)and the remaining (partition no.3) is under FFS (mount point /)

You'll need a floppy with free space on it. Mount the floppy using the mount_msdos command like so.

# mount_msdos /mnt /dev/fd0c

In OpenBSD, there is no /boot/boot1 equivalent. Thus we'll have to create one manually. Luckily this is simple and straightforward.

# dd if=/dev/rwd0c of=/mnt/open.bsd bs=512 count=1

Once completed, reboot into Windows using

# umount /mnt; shutdown -r now

and copy "open.bsd" to where boot.ini and ntldr are located. Edit your boot.ini to include the line cpen.bsd="OpenBSD". Reboot and you'll have a choice.
What happens here is that the XP boot menu does give me a choice, but on selecting it, the system just reboots.

Then, I tried intalling OS-BS. I told it to give me a choice between WinXP Pro(partition 1) and OpenBSD(partition 3) but it just says no OS when I select partition 3.

Then I tried installing BootEasy. Same problem.

The files on wd0a(the OpenBSD partition) do exist because when I boot from the Install floppy, go to the shell and say:
mount /dev/wd0a /mnt
It is successful and a ls /mnt shows all the files.

Any suggestions?

Thanks in advance,