Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Feb 2002

    linux networking

    k ill start off saying who ever replies to this must be very Patience ! because i have had linux for only 3 days now

    i am running red hat linux 7, thru a linksys router to cable modem
    i can ping router
    cant connect to internet

    any ideas?

  2. #2
    Senior Member
    Join Date
    Oct 2001
    I have the exact same setup on one of my machines. The first time I encountered this problem, I fought it for hours. It's really a very simple problem, but when you're a Linux newbie, it seems like a mountain. You just don't have your gateway address in the configuration. Go back through the network configuration procedure, and make sure you got it all. If it still doesn't work, I can get you some file names where you can set it manually. That's what I had to do. The only hard part is finding the files.

  3. #3
    Senior since the 3 dot era
    Join Date
    Nov 2001
    Hey ChipPunk RedHat 7.0 lets you install the network configuration when you do an install, so if you really can't find the settings or files... re-install, however this is a stupid solution to your problem.

    to solve your prob: make sure all connections and your NIC are working, then make sure your IP settings and default gateway are correct.
    to do that, do the following: log in
    got to an Xterm, get root access by typing su - after you've done that, enter your root password. Type Linuxconf enter the network tab in linuxconf, enter your IP adress, perhaps your linksys can do DHCP? If it does, leave your IP adress blank and set IP settings to auto recieve (DHCP) ; otherwise manual: enter your IP (something like and submask now you have to enter the default gateway and DNS. Ok. press accept and quit Linuxconf.

    Now your back in your Xterm. Enter the following commands (assuming you have your NIC at eth0 and you have chosen as IP adress for your box and four your Gateway box)

    ifconfig eth0 netmask up

    route add -net 192.1.ethernetmask eth0

    route add default gw eth0



    now your connection should be working fine
    however don't shoot me if I accidentally typed some mistake here...

  4. #4
    Senior Member
    Join Date
    Jan 2002


    Stflook is exactly right....I would just like to give an explanation why.

    Your router obviously has 2 physical interfaces. One interface sits on your internal network and the other is on the network that connects to your ISP. Now since you are the same network segment as the internal interface of the router, you will be able to ping the router no problem. Any traffic that is destined for another network other than your own (in this case the Internet) does not know where to go, and if you do a ping you will get "destination host unreachable". By setting the default gateway on your machine, you are telling your machine that for any IP address that is not on it's same network, send it to a router to route the traffic (the default gateway)

    Another way to test this and verify that it is not your Internet connection itself, is to ping the IP address of the external interface on your router, if you get the same response, it is because the traffic does not know where to go (or it is a bad router, which is not likely )

    I know for some of you guys this might be easy, but for any noobs that have ever wondered what exactly the default gateway setting is for, now you know!!

  5. #5
    Junior Member
    Join Date
    Feb 2002


    it up and online
    thx guys for helping me

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.