Linux Dual Boot... No Go.
Results 1 to 7 of 7

Thread: Linux Dual Boot... No Go.

  1. #1
    Junior Member
    Join Date
    Mar 2002
    Posts
    1

    Angry Linux Dual Boot... No Go.

    Alright everyone, let me first give you some information. I'm running an old Dell Dimension XPS T600 system. 32MB video card, 256 RAM, 12GB primary, and 30GB secondary hard drive, DVD drive, and a burner.

    Now, I've followed the instructions like a cookbook as to how to install RH Linux 6.1. I got to the part about the partitioning, and I left half the primary drive for RH, and half for Windows 98. Now, here's the funny thing. From what I gather, I dont think that my BIOS supports dual-booting! I downloaded the update from Dell, and that didnt correct the problem, so I deleted Linux and reinstalled Windows and tried it again, same problem. So, I'm lost. Any suggestions as to what I should do?

  2. #2
    AO French Antique News Whore
    Join Date
    Aug 2001
    Posts
    2,126
    Did you check if your MBR was protect from Virus? (Go in BIOS to check to Anti-Virus Protection and disable it). Your problem is where you put your Lilo.. If you're unable to boot in the MBR, put in the first block of your active partition (PBR) (C Drive).

    By the way, BIOS have to nothing to do Dual Booting, either that it's a Dell that made.

    Hope it help.
    -Simon \"SDK\"

  3. #3
    Antionline Herpetologist
    Join Date
    Aug 2001
    Posts
    1,165
    What exactly does the Linux install say? If it says something about 1024 cylinder boundary, you need to have a linux boot partition at the beginning of your drive. Just create a partition <50MB at the absolute beginning of your drive (ext2) and specify the mount point as /boot. Then create your windows partition and then your linux partition(/). After that install windows and then linux. It should work fine.
    Cheers,
    cgkanchi
    Buy the Snakes of India book, support research and education (sorry the website has been discontinued)
    My blog: http://biology000.blogspot.com

  4. #4
    Senior Member
    Join Date
    Oct 2001
    Posts
    638
    From what I gather, I dont think that my BIOS supports dual-booting!
    From the information that you have given I doubt that your BIOS is the problem. DELL is a fairly reptutable dealer so it's probably something else. I know that they did put out a patch on the bios for the XPS T600 because of a fault but I don't think that this is related to the problems that you're having.

    The best advice that I can give you is to scratch Redhat 6.1 and upgrade to 7.2. Redhat 7.2 doesn't use LILO as the default boot loader anymore. LILO has been replaced by GRUB which is more powerful and flexible. GRUB supports just about every file system that exists and has no problems with the whole 1024 cyclinder limit thing. So you could have your linux partition as big as you want or have WIN98 and Redhat on separate drives.

    I would also make sure that when you are installing Redhat that BIOS is checking your linux partition for the boot loader first. Make sure that /boot is being pointed to as the first partition to load and that the boot loader is installed here properly.

    If you have already tried these things, please give some more information about your BIOS and settings. I'll try to help .
    OpenBSD - The proactively secure operating system.

  5. #5
    Member
    Join Date
    Sep 2001
    Posts
    36

    Arrow

    The problem doesn't come from your BIOS, I think...
    What I recommand you is to install FIRST win98se, and then install linux.
    'cause if you first install linux, and then win98, win98 will erase your MBR, deleting your linux loader (lilo or grub).
    Hope it helped

  6. #6
    Senior since the 3 dot era
    Join Date
    Nov 2001
    Posts
    1,540
    Remark: sniper001 It's not really a prob if win98 deletes your linux loader, cause on installation you have been asked to create a boot disk. Therefor you can start with that disk and run linuxconf and point everything (boot, /, swap) to the right partition and check "write lilo into MBR". Doing this will rewrite lilo to your MBR. However I agree with you, the easiest setup is create a small Linux boot partition, create a DOS / windows partition and a non-dos partition; install Win98 to the DOS partition and after that install Linux to the non-dos partition.

  7. #7
    Member
    Join Date
    Sep 2001
    Posts
    36
    Yep, you're right. If you cared to create a boot disk for linux, no problem : you can also edit lilo.conf and lunch lilo as root : it will automatically rewrite your MBR

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •