Nbtstat -command???
Results 1 to 4 of 4

Thread: Nbtstat -command???

  1. #1
    Join Date
    Dec 2001

    Nbtstat -command???


    Im running "win2k pro", with "tiny firewall", and am having some configuration problems, with the nbtstat command, when i run the command on any host, with my firewall enabled it will give the output "host not found", and then when i disable the firewall it will list the "name table". Soo i think i narrowed it down to firewall configuration problem, can anyone help me on how to configure my firewall soo it will let me run this command.... if what i am trying to explain is not clear, here is what i mean.....
    C:\>nbtstat -a 1xx.x7x.x5.x9

    "FIREWALL - disabled"

    Local Area Connection:
    Node IpAddress: [1xx.x7x.x5.x9] Scope Id: []

    NetBIOS Remote Machine Name Table

    Name Type Status
    BARBIE-316 <03> UNIQUE Registered
    BARBIE-316 <03> UNIQUE Registered

    MAC Address = xx-x8-xx-8x-Cx-x4

    "FIREWALL -enabled"
    C:\>nbtstat -a 1xx.x7x.x5.x9

    Local Area Connection:
    Node IpAddress: [1xx.x7x.x5.x9] Scope Id: []

    Host not found.

    2>And soo i dont waste another post, i tryed to look for a tutorial on how to disable listening ports, like 135,139 <---(i disabled "file and print" but it is still listening), 445 but, cant find anything other than getting a firewall and blocking them.. Is that the best solution?? Or can you go into "control panel"-"services" and play with some of those setting to turn them off??? Like i know 135 is for "DCE endpoint resolution" but how do i disable it?? THANKS

  2. #2
    Senior Member
    Join Date
    Jan 2002
    It depends on the type of firewall you are running, but all you have to do is enable windows networking or windows filesharing or netbios over TCP/IP. whatever it is called in your personal firewall.

    The reason it is not working is because nbtstat relies on netbios for it's lookups. Since the firewall is blocking it, it willl not work. Ideally you will only want to allow netbios outbound on your firewall, but I am not sure what firewall you have to tell you exactly how to do it.

    If you want to disable netbios on your machine, you must go to the network properties and disable netbios over TCP/IP in your adaptor settings. a firewall will not shut down the service, so you will still see the ports when doing a netstat. But the firewall will block any connections from accessing that port.

    Let me know if you need more help...i know this is a very quick description...

  3. #3
    AntiOnline Senior Member souleman's Avatar
    Join Date
    Oct 2001
    Flint, MI
    like 135,139 <---(i disabled "file and print" but it is still listening)
    ummm, doesn't nbtstat use port 139 to get the information from the machine.
    \"Ignorance is bliss....
    but only for your enemy\"
    -- souleman

  4. #4
    Junior Member
    Join Date
    Jan 2002
    I had the same problem when I installed Zonealarm to my Win2k box. When Zonealarm asked me if I wanted to allow NetBios to access my local network and internet, I clicked on yes and it worked fine after that. But I got paranoid that I'd get scanned so I stealthed those ports again and I unbinded MS File and Printsharing to make sure.
    We are what we know; Feed your head!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts