Problems compiling Qt tutorials
Results 1 to 4 of 4

Thread: Problems compiling Qt tutorials

  1. #1
    Antionline Herpetologist
    Join Date
    Aug 2001
    Posts
    1,165

    Unhappy Problems compiling Qt tutorials

    After hearing so many good things about Qt, I decided to learn it. So I fired up the tutorials and typed in the first tutorial program. When I tried to compile it like so:
    gcc -I"/usr/lib/qt-2.3.1/include" qt1.cpp
    I got a bunch of errors about it not finding certain classes and constructors. Any idea what's wrong?
    Cheers,
    cgkanchi

  2. #2
    Senior Member
    Join Date
    Nov 2001
    Posts
    472
    Try this instead:
    g++ -I$/usr/lib/qt-2.3.1/include qt1.cpp -o qt1 -L$/usr/lib/qt-2.3.1/lib -lqt

    Don't ask what it all means, but this will work!
    ---
    proactive

  3. #3
    Antionline Herpetologist
    Join Date
    Aug 2001
    Posts
    1,165
    Whoops I used g++ too. But I'll try this particular syntax anyways.
    Cheers,
    cgkanchi
    Buy the Snakes of India book, support research and education (sorry the website has been discontinued)
    My blog: http://biology000.blogspot.com

  4. #4
    Antionline Herpetologist
    Join Date
    Aug 2001
    Posts
    1,165
    I got it working. Thanx proactive. Greenies for you
    Cheers,
    cgkanchi
    Buy the Snakes of India book, support research and education (sorry the website has been discontinued)
    My blog: http://biology000.blogspot.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •