Mandrake 8.2 help
Results 1 to 9 of 9

Thread: Mandrake 8.2 help

  1. #1
    Senior Member
    Join Date
    Sep 2001
    Posts
    800

    Mandrake 8.2 help

    Hey y'all,
    I just installed mandrake 8.2 on my box and booted it up. When I logged on I logged in with root under KDE. Now the problem that i am getting is that when I try to open up the cdroms(DVD, CDRW) or the floppy it says that this user does not have permission.
    How can root not have permission? How can I access my cdroms or floppy?

    thanks all in advance.
    [gloworange]\"A hacker is someone who has a passion for technology, someone who is possessed by a desire to figure out how things work.\" [/gloworange]

  2. #2
    Member
    Join Date
    Apr 2002
    Posts
    72
    Thats strange, saying root doesn't have permission.
    Are you sure the correct drivers are installed for the drives, or have you tried not logging in as root, or logging in without using KDE?
    live life, don\'t just endure it

  3. #3
    Senior Member
    Join Date
    Mar 2002
    Posts
    425
    I'm not all that familiar with Mandrake, so please don't flame me if things are set up differently from RedHat, but in RedHat you could go to the /dev directory and take a look at the cdrom device. I think it should be similar if not the same in Mandrake. Use ls -l /dev/cdrom* and see if it's a link. If it is, then also at whatever it's pointing to. Check the permissions on these files. If they're owned by root, but somehow had their permissions corrupted, that could cause your problem.

  4. #4
    Senior Member linuxcomando's Avatar
    Join Date
    Sep 2001
    Posts
    430
    well try doing this and see if it works.......open up an xterm and type mount /mnt/cdrom or mount /mnt/floppy
    then cd to the mounted dir....does that work?
    I toor\'d YOU!

  5. #5
    Senior Member
    Join Date
    Feb 2002
    Posts
    856
    Hi,
    Try this:
    1)Click on Mandrake Control Center icon on desktop
    2)Click on Mount Points
    3)Click on options
    4)Select both the "user" and "supermount" options
    5)click Ok
    6)When prompted "Do you want to save the changes to etc/fstab?" click "yes."
    Reboot the system; stick a cd in the cd tray, click on the cd icon and see what happens.

    You may also want to go into "Userdrake" and add your regular users to the "cdrom" and "cdwriter" groups.
    For the wages of sin is death, but the free gift of God is eternal life in Christ Jesus our Lord.
    (Romans 6:23, WEB)

  6. #6
    Senior Member
    Join Date
    Sep 2001
    Posts
    800
    OK all
    I tried logging in with Gnome and the CDs work fine. Its just under KDE. I downloaded KDE 3 to try and see how that works. Thanks for all the help.
    [gloworange]\"A hacker is someone who has a passion for technology, someone who is possessed by a desire to figure out how things work.\" [/gloworange]

  7. #7
    AntiOnline Senior Member souleman's Avatar
    Join Date
    Oct 2001
    Location
    Flint, MI
    Posts
    2,884
    Are you having problems looking at the information on the cd, or opening up the acutal drive?

    If you can't see the info on the CD, that means it isn't mounting properly.

    If you can't open the drive, then you are not unmounting it properly. If you right click on the cd icon, there is an unmount option. If that doesn't work, open a terminal, and type "umount /mnt/cdrom" without the quotes of course.

    btw, you shouldn't login as root you can mess up a lot using xwindows as root. Its much better to login as a user, and if you need root, open a shell and su -.
    \"Ignorance is bliss....
    but only for your enemy\"
    -- souleman

  8. #8
    Senior Member
    Join Date
    Sep 2001
    Posts
    800
    Originally posted here by souleman
    Are you having problems looking at the information on the cd, or opening up the acutal drive?

    If you can't see the info on the CD, that means it isn't mounting properly.

    If you can't open the drive, then you are not unmounting it properly. If you right click on the cd icon, there is an unmount option. If that doesn't work, open a terminal, and type "umount /mnt/cdrom" without the quotes of course.

    btw, you shouldn't login as root you can mess up a lot using xwindows as root. Its much better to login as a user, and if you need root, open a shell and su -.
    I cant even open it up. I go in through file manager and goto /mnt/ and look at what is there and /mnt/cdrom, /mnt/cdrom1 and /mnt/floppy all have a padlock picture on them. I try clicking them and they say I dont have the permission. I have captured a screenshot of it but its on my home computer and i am at work.

    I know I shouldnt log in as root but I was just trying to access my CDRoms and install some programs before I log in as my user name. I am still learning though so go easy on me.
    [gloworange]\"A hacker is someone who has a passion for technology, someone who is possessed by a desire to figure out how things work.\" [/gloworange]

  9. #9
    Antionline Quitter..Srsly
    Join Date
    Aug 2001
    Posts
    457
    i hate KDE yet for some stupid reason most *nix has it maybe u should mount the drivces again or change the permissions on the drivers...probably wont work but if it workds on Gnome u dont neeed KDE get rid of it
    \"\"A weak mind is like a microscope, which magnifies trifling things but cannot receive great ones.\" G.K. Chesterton, 19th-century English essayist and poet\"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •