Results 1 to 6 of 6

Thread: Lilo Mbr

  1. #1
    Join Date
    Oct 2001

    Lilo Mbr

    ok, i know this isnt quite 'secutiry' per se but in is *nix so.....

    ok i tried upgrading from 2.4.10 kernel to 2.4.17 i got everything compiled and
    everything made right ( i think, it didnt tell me otherwise, it would have,
    wouldnt it?)then it all started to go wrong. i followed the directions in the
    README file and did everything it said. ran lilo as root to update the MBR (i
    presume) and then i rebooted when it was done..... with my new kernel..... or so

    i thought.

    it dose its "loading linux..............................." thing then linefeed
    and it just blinks at me........ the curser. so then i tried to get into the
    "safe mode" and that did the same thing. then i finally gave up and booted from
    the CD MBR and told it to "load the intalled OS" so then it runs fine. ok so the

    system isnt down, its just a pain in the ass to bring back up. so any way, i
    restored the original kernel (the one that was there before i changed the link)
    and updated the lilo.conf then told it to run lilo to update the MBR again.....
    it didnt load it right! it tells me some file ( think it was some thing like
    loadrd) cant be found. then i tell it to be verbose.... after finding the right
    verbose level it says that the file gets created and put on the ramdisk (i think

    thats where it was) but the link is there so........ then it tells me that the
    file isnt there when it clearly is! only after that dose the program clean up
    and delete the file. so damn it i cant figure this out and i think im working on

    memorizing the lilo man page by now! aaarg! yes is tried -s and -S..... i tried
    the command that it recomends in the man page to restore the MBR to what it
    was.... and it still wont do it!

    ok, i have a headache (i got a few kicks to the head today) and im really tired,

    so with luck there will be the magic post in the morning that saves the day.

    thanks all! later

  2. #2
    Antionline Quitter..Srsly
    Join Date
    Aug 2001
    i dont knwo but i will bump it up so that others can help ya
    \"\"A weak mind is like a microscope, which magnifies trifling things but cannot receive great ones.\" G.K. Chesterton, 19th-century English essayist and poet\"

  3. #3
    Senior Member
    Join Date
    Sep 2001
    you could try using Buildkernel
    it'll assist you and help in recompiling your kernel(s) without causing any lasting damage.
    it's nice as it sorts out your lilo and all the boring stuff.

    [glowpurple]manually editing your config files can break them. If this happens, you get to keep both pieces. [/glowpurple]

  4. #4
    I'm not sure if this is related or not, but I thought I'd throw it out there just in case it helps. I'm a freak when it comes to knowing why certain things are on my computer, so I've constantly going through files on my linux system trying to figure out what exactly they do. Well, beginning with 7.2, RedHat began to create a /initrd directory. Since I'd never seen it before, I took a look at it and it was empty. Hmm.. that's weird, well, if there's nothing in it, then I'll just delete it... Bad idea. The system never would come back up until I booted into rescue mode and recreated that directory manually. Apparenty the system copies temporary files into that directory during bootup or something, because it definitely needs that empty directory.

    Also , have you gone through the mkinitrd process? I don't remember the exact process, but I'm sure you can google it. It's also an integral part of installing a new kernel, but it's a little less obvious.

  5. #5
    Join Date
    Oct 2001
    thats it, initrd..... when i ran lilo it created the dir then deleted it after it failed to find anything in it or something....... so ire created the directory and it still complained, tho didnt delete it........ havent tried rebooting with the directory there but i dont see how it would make a lot of diference if i cant tell the damned MBR to use it however the hell it wants to...... aaaaaarg! ill create he dir tonite and when i boot in the morning, if it works then ill be back to say, if it dosnt work then damnit! i REALLY hate to take my ols M$ approach and reinstall the friggin OS! god some times i think the data los would be worth the lack of hasle....... damned new-fangled kernels! he he he

  6. #6
    Well, there should be a /initrd directory and a file in /boot called initrd-2.4.18-4.img or whatever your current version is. As an example, you would compile your kernel, install the kernel in /boot, then run:

    mkinitrd /boot/initrd-2.4.18-4 2.4.18-4

    where you would of course change the number to match your kernel. Then you need to edit /etc/lilo.conf accordingly to point both at the new kernel and the new initrd. And run lilo -v -v to make sure everything installs correctly. I hope this helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts