open port
Results 1 to 6 of 6

Thread: open port

  1. #1
    Member
    Join Date
    May 2002
    Posts
    63

    open port

    I scaned my box for open ports and found that port 6000 which nmap says its X11 is open does anyone know what this is or how to close the port if it doesnt need to be open? thanx trials
    If its not broken it can still be inproved.

  2. #2
    Just a Virtualized Geek MrLinus's Avatar
    Join Date
    Sep 2001
    Location
    Redondo Beach, CA
    Posts
    7,324
    X11 I believe is for Xwindows. Generally I've noticed that XWindows of a variety of types is either on port 3000 or 6000.

    You might want to check out a site like this
    Goodbye, Mittens (1992-2008). My pillow will be cold without your purring beside my head
    Extra! Extra! Get your FREE copy of Insight Newsletter||MsMittens' HomePage

  3. #3
    Senior Member
    Join Date
    Nov 2001
    Posts
    1,255
    I'd recommend firewalling off port 6000 if you can using either ipchains or iptables. Also, there is a parameter you can pass to startx that goes --nolisten tcp. If you add that, it should not listen on any TCP ports. I believe the default behaviour was changed in XF4.1.x and up so that it won't listen on any TCP ports by default.

    It's always good to learn to firewall your box though.
    Ipchains HOWTO
    Netfilter (AKA Iptables) HOWTO
    Chris Shepherd
    The Nelson-Shepherd cutoff: The point at which you realise someone is an idiot while trying to help them.
    \"Well as far as the spelling, I speak fluently both your native languages. Do you even can try spell mine ?\" -- Failed Insult
    Is your whole family retarded, or did they just catch it from you?

  4. #4
    Member
    Join Date
    May 2002
    Posts
    63
    thanx for you help, where abouts do you out the parameter that you pass to start x? im runniing mandrake 8.2 and X starts when the system boots up. thanx trials
    If its not broken it can still be inproved.

  5. #5
    Senior Member
    Join Date
    Jul 2001
    Posts
    461
    correct me if I am wrong but....

    Make sure you only block that port coming inbound from the network. dont block connections from localhost to localhost, or you wont be able to run xwindows.

  6. #6
    Senior Member
    Join Date
    Nov 2001
    Posts
    1,255
    Originally posted here by trials
    thanx for you help, where abouts do you out the parameter that you pass to start x? im runniing mandrake 8.2 and X starts when the system boots up. thanx trials
    I'm unfamiliar with mandrake, but automatically booting to X is runlevel 5, so there should be a script in /etc/rc.d/rc5.d.

    Do the following:
    Open up a console.
    Su to root.
    Cd to /etc/rc.d/rc5.d
    Do grep startx *. It should turn up one or more results.
    Edit the files it shows you, and change the startx command to read startx --nolisten tcp.

    correct me if I am wrong but....

    Make sure you only block that port coming inbound from the network. dont block connections from localhost to localhost, or you wont be able to run xwindows.
    Actually, this won't affect X at all if you tell it to ignore TCP.
    Chris Shepherd
    The Nelson-Shepherd cutoff: The point at which you realise someone is an idiot while trying to help them.
    \"Well as far as the spelling, I speak fluently both your native languages. Do you even can try spell mine ?\" -- Failed Insult
    Is your whole family retarded, or did they just catch it from you?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides