Installing JRE
Results 1 to 5 of 5

Thread: Installing JRE

  1. #1

    Installing JRE

    Alright, i have been trying to tackle j2re-1_3_1_04-linux-i586-rpm.bin for a while now. Ive tried multiple versions of jre, im on redhat 7.3 and cant get it working properly. Or working at all for that matter. If anyone can help, i would be much ablidged. and i have read the installation HOWTO's and the readme's for them, but the didnt seem to help. any helpful input would be appreciated. Thanks.

  2. #2
    Ok, I'm not sure what stage you're at, so I'll start from the beginning. Forgive me if I cover something you already figured out.

    1. After downloading the file, you need to set permissions for it: chmod 700 j2re-1_3_1_04-linux-i586-rpm.bin

    2. This will run a program which makes you "read" the license agreement and type 'yes' to agree to the license.

    3. The program creates an rpm in the same directory that the .bin file is in. You then install the rpm by running:

    rpm -Uvh j2re-1_3_1_04-linux-i586-rpm

    4. By default, the rpm installs most of the important files in /usr/java/j2re-1_3_1/ or something similar.

    5. In order to run java programs, you'll either need to type the full path each time you want to run java, or do something like this with your path:


    6. Then to run programs, you just type:

    java program_name

  3. #3
    ok the chmod 700 command didnt work, it just returns as follows:
    root@localhost er0k]# chmod 700 j2re-1_3_1_04-linux-i586-rpm.bin
    root@localhost er0k]#

    so whats the problem with that, i tried various ways to enter that just in case i didnt read the correct syntax from your post, but i cant get it to work. Any ideas? Thankyou for your help.

  4. #4
    Hi mom!
    Join Date
    Aug 2001
    chmod isn't supposed to give you back any result. do a 'ls -als' and you'll see that the line containing the file has -rwx------ in front of it.

    This is how the encoding scheme works:
    Those 10 characters represent the access to that file/directory, the last 3 are user specific, the group of tree before those are group-specific, and the three before that are for root only (or the owner of the file, I'm not sure).

    r gives read-access
    w gives write-access
    x gives execute access

    So, if the last three characters of that line read r--, the users that fall in that category have only read-access to the file.

    What about the numbers, then? RWX is encoded in numbers: R=4, W=2, X=1. Add all the numbers which apply, and there's the number you use:
    chmod 735 will result in -rwx-wx-r-x for that file:

    7 = 4 + 2 + 1 ( or, R and W and X )
    3 = 2 + 1 ( or, just W and X )
    5 = 4 + 1 ( R and X )
    I wish to express my gratitude to the people of Italy. Thank you for inventing pizza.

  5. #5
    I think er0k was a little confused with what str34m3r had originally said. When you chmod 700 it makes the file readable, writeable, and executable by the owner. Once you have made the file executable, execute this command:


    This will create the rpm for you to install. Once the rpm is made then execute the command:

    rpm -Uvh j2re-1_3_1_04-linux-i586.rpm <or whatever the name of file is>

    This will install JRE in the path /usr/java/j2re-1_3_1/ or something like that. Add this to your PATH and you'll be able to run programs that require java. This is how I had to install JRE for using Limewire for Linux. Now, I did this on a Mandrake distribution but it should be pretty much the same. Hope this helps.

    the eeshman

    Right after my last post I found this on Java's website:

    This should help you out if all else fails....

    -the eeshman

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts