Need help with compiling kernel
Results 1 to 5 of 5

Thread: Need help with compiling kernel

  1. #1
    Senior Member
    Join Date
    Feb 2002
    Posts
    856

    Need help with compiling kernel

    Hi,
    I'm using Slackware 8.1. Unfortunately, none of the default kernels that come with the distro support my sound card. So I'm having to recompile the kernel. When I get to the "make bzImage" step, I get this set of error messages, _

    BASENAME=ymfpci -c -o ymfpci.o ymfpci.c
    gcc -D__KERNEL__ -I/usr/src/linux-2.4.18/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -pipe -mpreferred-stack-boundary=2 -march=i686 -DKBUILD_BASENAME=msnd -DEXPORT_SYMTAB -c msnd.c
    make[3]: *** No rule to make target `/etc/sound/msndperm.bin', needed by `msndperm.c'. Stop.
    make[3]: Leaving directory `/usr/src/linux-2.4.18/drivers/sound'
    make[2]: *** [first_rule] Error 2
    make[2]: Leaving directory `/usr/src/linux-2.4.18/drivers/sound'
    make[1]: *** [_subdir_sound] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.4.18/drivers'
    make: *** [_dir_drivers] Error 2
    bash-2.05a#

    I can't continue the compile process after this. Does anyone know what the problem is and how to fix it? Thanks.
    For the wages of sin is death, but the free gift of God is eternal life in Christ Jesus our Lord.
    (Romans 6:23, WEB)

  2. #2
    Old-Fogey:Addicts founder Terr's Avatar
    Join Date
    Aug 2001
    Location
    Seattle, WA
    Posts
    2,007
    *bump*

    This is like the blind leading the blind, but does /etc/sound/msndperm.bin exist? Are you sure you have the whole kernel source, and all of it is from one version of the kernel? And that you ran 'make dep' and/or 'make clean' first?
    [HvC]Terr: L33T Technical Proficiency

  3. #3
    Are you making a monolithic kernel? No modules, or are you going with modules.

    Where did you get the kernel source. If its Mandrake that is your problem. (Mandrake does NOT have all the drivers)

    My suggestion is go with RedHat 7.3.

    However, www.kernel.org will give you a complete kernel 2.4.19 if you insist on building.

    Sorry Mandrake, Slackware is short.

    The only kernel source that you can trust is from the source.

  4. #4
    Senior Member problemchild's Avatar
    Join Date
    Jul 2002
    Posts
    551
    Usually when I see those kinds of errors, it means I've missed some sort of dependency in the kernel config. Most of the time I've either compiled a module's dependency as part of the kernel (or vice versa) and the compiler chokes on it for some reason, or I've just flat out missed something. What exactly do you have enabled in your sound options? Check and see that all of your sound-related options are compiled as either modules or in the kernel - not mixed - and see if you get any better results.
    Do what you want with the girl, but leave me alone!

  5. #5
    Senior Member
    Join Date
    Feb 2002
    Posts
    856
    Hi,
    thanks for you replies. I think ProblemChild has the answer. It was a dependency problem.
    For the wages of sin is death, but the free gift of God is eternal life in Christ Jesus our Lord.
    (Romans 6:23, WEB)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •