win2000pro&RHlinux7.2
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: win2000pro&RHlinux7.2

  1. #1
    Member
    Join Date
    Mar 2002
    Posts
    94

    Question win2000pro&RHlinux7.2

    Previously I had win98se as my OS.Later
    I had installed redhat 6.2 along with 98se. Everything
    went fine and during boot I was getting the option to select
    from win98 or linux.

    Okay now heres the problem.I upgraded my system I installed
    win2000pro on NTFS. Then RHlinux7.2. But when I boot the system
    it goes straight to win2000 and I dont get to select
    which OS to boot to. If i want to use linux I have to boot the
    system with linux boot disk.

    Why is that I dont get the option to select the OS?.
    Also is there any software which does this?. Please help.Thanx.
    Attitude is a small thing that makes a BIG difference.

  2. #2
    The Iceman Cometh
    Join Date
    Aug 2001
    Posts
    1,210
    It sounds as if, when you installed Red Hat, you did not install one of the boot manager, instead relying upon a boot disk to get into Red Hat. I'm not sure if you can install a boot manager after Red Hat is already installed (though, I'm pretty certain there probably is a way), but you could always just reinstall Red Hat and install LILO or another boot manager.

    AJ

  3. #3
    Senior Member
    Join Date
    Sep 2001
    Posts
    800
    did you install a boot manager in the MBR? or boot sector?
    I had to do that to get mine to work. But I also created a little 20 partition at the very beggining of the hard drive and set it up as fat32.
    try this 20 meg partition first fat32, win2k partition 2nd, linux after that and install Lilo in master boot record.
    [gloworange]\"A hacker is someone who has a passion for technology, someone who is possessed by a desire to figure out how things work.\" [/gloworange]

  4. #4
    Member
    Join Date
    Mar 2002
    Posts
    94
    I has used the LILO booter. But still no use. If i remember right i think i installed it in the boot sector. I think it has something to do with partitions on my hard drive. Let me see. Any more suggestions guys?
    Attitude is a small thing that makes a BIG difference.

  5. #5
    Banned
    Join Date
    Oct 2001
    Posts
    1,463
    Windows 200 overwrites the MBR when it is installed

  6. #6
    The Iceman Cometh
    Join Date
    Aug 2001
    Posts
    1,210
    That partitions shouldn't make a difference if your LILO is configured correctly. If you reinstall LILO, it should automatically reset the settings to allow you to boot into Windows again. If it doesn't, you should be able to manually configure the boot file so that it will show Windows. Check out some tutorials about configuring LILO online. Google had a bunch of hits when I tried it, and a few of them cover this specific topic.

    AJ

  7. #7
    Banned
    Join Date
    May 2002
    Posts
    46
    try loading grub instead of lilo,
    i had no success w/ lilo, but i got it to work w/ grub,

    you have to install w2k first then rh

  8. #8
    Boot with your Linux bootdisk and then run "lilo" in your root console.

  9. #9
    Senior Member problemchild's Avatar
    Join Date
    Jul 2002
    Posts
    551
    Actually, Windows 2000 Professional *doesn't* overwrite the MBR, so it doesn't matter which you install first in this particular case. It's the only member of the Windows family that doesn't, oddly enough. Bill must've been asleep at the wheel the day that one slipped out the door.

    Red Hat 7.2 uses grub by default instead of lilo. Grub labels drives and partitions starting at 0, so (hd0,4) would be the first disk and first logical partition and (hd0,0) is the first primary partition of the first disk. If you've chosen grub as your boot manager, run grub from the command line and then execute the following commands from within grub:

    root (hd0,4) (or wherever /boot lives)
    setup (hd0)
    quit

    Then check /boot/grub/menu.lst and be sure everything is in order there. If you chose lilo instead of grub during installation and chose to istall it in the boot sector instead of the MBR, edit /etc/lilo.conf and be sure there is a line that reads

    boot=/dev/hda

    and run /sbin/lilo

    That should fix everything up nicely.
    Do what you want with the girl, but leave me alone!

  10. #10
    Member
    Join Date
    Mar 2002
    Posts
    94
    Wow..thats a lot of options for me to try.. Acid i had installed win2000 before i installed Rh7.2.
    So win2000 didnt do anything. I have installed Rh7.2 around 8 to 10 times now trying outdifferent ways to get the booter. getting irritated. .. I have tried editing the boot.ini in windows. Is there a way thru that? Let me try out grub booter maybe that will work. Also a serach as adven said. thanks for your help guys...hope it works out this time...here i go again installing RH7.2 ...
    Attitude is a small thing that makes a BIG difference.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •