Web server woes...
Results 1 to 4 of 4

Thread: Web server woes...

  1. #1

    Web server woes...

    I have encountered a problem updating my web page. I have several computers on a network (700-800) and I have been able to access and save files to my web server in the past. My web server is a Windows NT server version 4.0. I don't have the option to upgrade, or switch operating systems thus I have to fix the problem. The problem seems to be a permissions thing and I can't for the life of me fix it. A share called wwwroot exists on the server with certain users/groups having access to it to varying degrees. Under this folder are folders that belong to different offices who have permissions to these folders for updating purposes. However, everything under the wwwroot directory is inaccessable other than read-only to anyone not logged in directly to this server. I have searched MS technet for answers an nothing seems to fit my dilemma. I need to restore the permissions to these offices as soon as possible. Has anyone ever seen this kind of error or experienced something similar to this? Thanks.

    -the eeshman

  2. #2
    Senior Member
    Join Date
    Jan 2002
    Posts
    1,207
    Have you checked the share permissions as well as the filesystem permissions?

    The access rights you get on a file/directory on a share on NT are determined by the share permissions *and* the file permissions - if you have read-write on one but only read-only on the other, you will still only be allowed read only access.

    By "logged directly on the server", I assume you mean logged on to the console.

    Users logged on the console don't need to access the files through a share, which suggests that the share permissions are wrong. There's also a possibility that you've assigned the special group "INTERACTIVE" to the ACL - "INTERACTIVE" I believe only includes local logins, not network users.

  3. #3
    Slarty, you are the bomb. I can't believe I overlooked something that simple. I had been racking my brain for 2 days with no sleep (perhaps rest would have done me good). I added the web admin group to the share with appropriate permisisons. You have truly been a lifesaver. Thanks.

    -the eeshman

  4. #4
    Senior Member
    Join Date
    Apr 2002
    Posts
    889
    Don't ask me why because there is no reason for it other then it being an M$ product. I have run across this in the past and cleared the problem up by removing a group, or person from the permissions, shut off IIS then turn it back on and re-add the group or person and permissions were restored. Also had this problem with network printers just picked a different IP then put the old IP back. It may have to do with corruption of the JET database because I noticed errors there and the loss of printers or permissions with NT 4.0. Give it a try as well as rebuliding the JET database. I know makes no sense but that's what worked for me.
    I believe that one of the characteristics of the human race - possibly the one that is primarily responsible for its course of evolution - is that it has grown by creatively responding to failure.- Glen Seaborg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides