One of the things most commonly overlooked by the average person just getting started on a *nix system is the keeping current portion for security related reasons. Open BSD users be advised :

Systems affected:
All versions of OpenBSD.

Overview :
Insufficient boundary checks in the select call allow an
attacker to overwrite kernel memory and execute arbitrary code
in kernel context
It seems that all versions of OpenBSD are vulnerable under this, though patch information is available here.

for those of you running your OpenBSD systems, or any other OS for that matter, keep it up to date and try your best to keep it safe.