why cant i use 2.4.11?
Results 1 to 2 of 2

Thread: why cant i use 2.4.11?

  1. #1
    Banned
    Join Date
    Oct 2001
    Posts
    263

    Question why cant i use 2.4.11?

    ok i was just getting my friendly 2.4.19 patch and i noticed one block of files that names didnt fir the patern as i was scanning down....... 2.4.11-dontuse ...... the files names are "linux-2.4.11-dontuse.tar.bz2" why may i ask does kernal.org apend the 2.4.11 kernal with -dontuse? any one know? i remember reading that some M$ products got shipped with a worm on them somewhere like in korea or something like that just recently..... did something simelar happen the the .11 code?

    [edit]
    yes i know that its almost a year late
    [/edit]

  2. #2
    Senior Member problemchild's Avatar
    Join Date
    Jul 2002
    Posts
    551
    There was a total rewrite of the virtual memory system around 2.4.10 or 2.4.11 that broke the kernel, and the incident almost caused a fork in kernel development. Linus decided to include the new VM design because of some issues with the old one, but Alan Cox and some others were against such a major rewrite in the middle of a stable kernel series. Alan went against Linus and continued to include the old VM in his -ac line of patches, and it looked for a while like the kernel might actually fork. The dust has pretty much settled now, but that's the story.

    This is a perfect example of why it was *BAD* for Linus to wait over a year to open the 2.5 development branch. Kernel developers have to have a place to play with their new toys, and since there was no development branch open, they played in the stable tree. I hope they all learned something from it.
    Do what you want with the girl, but leave me alone!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •