" restricting applications on winXP problem"
Results 1 to 2 of 2

Thread: " restricting applications on winXP problem"

  1. #1
    Join Date
    Nov 2001

    Unhappy " restricting applications on winXP problem"

    hello everybdy

    plzzz kindly read the following paragraph

    "Restrict Applications Users Can Run (All Versions) Popular
    Category: Home > Security
    Windows gives the ability to restrict the applications that can be run by users on a workstation.

    Open your registry and find the key [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion \Policies\Explorer]

    Create a new DWORD value and name it "RestrictRun" set the value to "1" to enable application restrictions or "0" to allow all applications to run.

    Then create a new sub-key called [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion \Policies\Explorer\RestrictRun] and define the applications that are allowed. Creating a new string value for each application, named as consecutive numbers, and setting the value to the filename to be allowed (e.g. "regedit.exe").

    Restart Windows for the changes to take effect. "

    my box has winXP pro ,, with PIII,128 MBRAM,20 GB HDD,
    i have created one admin account,, one restricted acc ,,and one common for all (guest),,,
    now i folowed as per the above para instructions ,, as it is written tht current user and if i'm using my admin account then tht tantamounts to tht i will lock myself of opening regedit.exe(if i use regedit.exe as the application to stop from executing..) so then i go to my guest account ,, and go the above mentioned key and try to create a new DWORD value but to my suprise it doesnt write to the registry giving the pop up message " error writing to the registry "
    now i'm in a fix as to how to stop the other users from executing regedit.exe using the above method...
    any help is highly welcomed
    thanx in advance

  2. #2
    Junior Member
    Join Date
    Aug 2002
    log in to the restricted/guest account, goto regedit, hold down shift and right click regedit, select runas, enter the administrator account details and follow the "Restrict Applications Users Can Run" instructions (this may not work as you have restricted rededit on the administrator account, If thats the case use another registry editor or .reg file to unrestrict it)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts