Permissions Problem
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Permissions Problem

  1. #1
    Member
    Join Date
    Aug 2002
    Posts
    38

    Permissions Problem

    Hiii,

    I am trying to set up XP sooo i can have users with limited access be able to use msn messenger.. Ok soo this is what i did i logged in as "ADMINISRATOR" i went to EXPLORER and copied the shortcut "msmsgs.exe" into the "All Users" Profile in Desktop now when i log onto my account Tasha with limited permissions the the MSN messenger icon appears on the desktop but when i click it nothing happens??? Any Help Thanks

  2. #2
    Gray Haired Old Fart aeallison's Avatar
    Join Date
    Jul 2002
    Location
    Buffalo, Missouri USA
    Posts
    888
    I may be wrong, but I think you have to install msn messenger in each profile you use.
    I have a question; are you the bug, or the windshield?

  3. #3
    Member
    Join Date
    Jul 2002
    Posts
    39
    It depends on each acct. You actually can log in to msn messanger with numerous names, so it doesnt actually belong to one person. Where the problem lies is on the Xp side of things. It is how you set up the accts with each individual. You would need to let each individual access to msn messenger for them to have it. When you set up there acct it will give you an option on shared accts, I believe that is when you will be able to establish that.

  4. #4
    Member
    Join Date
    Aug 2002
    Posts
    38
    Okkk

    Sooo i downloaded MSN messenger and then tryed to install with TASHA (limited account) but was unable to install it casue i dont have permissions sooo i RAN the setup file as administrator and it installed but when i logged out of the account and logged in again and using tasha i was unable to access it all i clicked on it aND NOTHING happened????

  5. #5
    Junior Member
    Join Date
    Jul 2002
    Posts
    16
    Natasha-

    Is the MSN messenger on each account, working or not? What i mean is that Xp has MSN preloaded on each account. Or atleast on mine it did! So really i think, athough i might be wrong but, if you set it back so that each account has Admin as there access, then go into each account and indivdualy try to bring MSN into the account your on. So what your bacsiclly doing is giving everyone access then going into there accounts and (in explorer) make a short cut of MSN from the working One... from your account...Thats if your the one you use works.
    If that little paragraph doesn't work then go to your account and just re-install MSN messenger and it should install on everone elses account(that s what i would do)..

    The problem might sound like its bad but if you just snoop around im sure youll figur it out..its probebly not working on everyone elses accounts because you draged the .exe into each...

    BEST of LUCK

    fatal_breed

  6. #6
    Old Fart
    Join Date
    Jun 2002
    Posts
    1,658
    Natasha...I think the proper method is to 'drag' the entire messenger folder into the 'shared folder'...this should resolve the issue. If you want a little more detail, right click the messenger folder, choose properties, then click the 'sharing' tab while logged in as the administrator. Hope this gets it done for you!

    <EDIT> The proper filepath is C:\Documents and Settings\All Users\Documents
    Al
    It isn't paranoia when you KNOW they're out to get you...

  7. #7
    Member
    Join Date
    Aug 2001
    Posts
    90

    Question A little help!

    Okay, heres a question somewhat along the same lines as Natasha's.

    On my XP Professional box, I have two accounts. 'Administrator ' and 'people ' ( belonging to the 'Users ' group as specified by the XP GUI in the Control Panel ). I've been having issues with getting the 'people's account to run Messenger myself. The only time I manage to run it whilst logged on as [B]people{/B] is if I right click, and chose Run As > Administrator. But then, that kinda negates the point of me making a people's account for everyone else to use the PC, right? I've tried a few things that haven't worked, and I'll try to explain them as best I can.

    1. I did the whole 'Right Click on the file and go to Security' part, change the access permisions to allow Users group to execute the file MSMSGS.EXE. Logging into 'people ' gave me absolutely nothing.

    2. Back as Administrator , I thought that maybe the inheritance was a problem ( since Users probably couldn't access the directory itself. Its the Program files direcrtory on the root drive, but I'm sure y'all already knew that ). Disabling the inheritance, I set up the permissions again, giving both Users and Admin ( the group ) the permissions. The Admin account opened the file easily, but again people couldn't. Back to square one.

    3. An interesting thing I noted was that on a previous experimental account 'test ' ( Admin ), I downgraded the account to User, and this person was able to use Messenger. I don't know if this was a freak accident, or had something to do with some setting I messed up. Ofcourse, test was able to access everything, just like the Admin group.

    Now, my question is this. I want to create a user, that does not have permission to execute ANY .exe .com or .bat ( basically the 'dangerous' extensions ) on the PC. They should be allowed to execute files that the Admin has specified permissions for ONLY, like MSN, or ICQ, or even mIRC. Because the stuff my users download is a real headache and they've managed to mess up my PC a few times ( users - read as clueless kids & family members ). Thank God for firewalls and Anti-viruses, otherwise my PC would've become a playground.

    This is what I need help with. It would be great if someone could explain if and how this is possible. Will I have to set up a new group, with a new group policy? Or is the current 'User' group customizeable enough to do so? Help me out guys.

    Cheers
    I blame you cos my mind is not my own, so don't blame me if I trespass in your zone!

  8. #8
    Alright. If I'm not wrong, you will have to install msn messanger somewhere into the ALL USERS folder (anywhere you want it in the allusers folder). then make a shortcut in the all users/desktop folder.

  9. #9
    Gray Haired Old Fart aeallison's Avatar
    Join Date
    Jul 2002
    Location
    Buffalo, Missouri USA
    Posts
    888
    ummm, er, meester bob_dole_lpb look at this post by allenb1963

    Originally posted here by allenb1963
    Natasha...I think the proper method is to 'drag' the entire messenger folder into the 'shared folder'...this should resolve the issue. If you want a little more detail, right click the messenger folder, choose properties, then click the 'sharing' tab while logged in as the administrator. Hope this gets it done for you!

    <EDIT> The proper filepath is C:\Documents and Settings\All Users\Documents
    And now look at your post...

    Alright. If I'm not wrong, you will have to install msn messanger somewhere into the ALL USERS folder (anywhere you want it in the allusers folder). then make a shortcut in the all users/desktop folder.
    Am I not getting the full "view" of your post?
    I have a question; are you the bug, or the windshield?

  10. #10
    Member
    Join Date
    Jun 2002
    Posts
    35
    Something along the same lines, is it possible/how can I limit space in user folders with Win 2K?
    ERROR: No Keyboard Detected
    Press F1 to continue....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •