Bastille problems
Results 1 to 6 of 6

Thread: Bastille problems

  1. #1
    Senior Member
    Join Date
    Feb 2002
    Posts
    130

    Bastille problems

    Hi,
    I am a bit of a Linux newbie and have just been trying to secure my machine using theBastille-Interactive tool. I answered all the question and it was all going fine, that is untill I reset the computer. The computer reported 'error bastille does not seem to be enabled for runlevel 36' or something similar. When the computer restarts is says it is unable to determine its runlevel and gives another error. Anybody have any ideas, probbaly something really simple I have overlooked, but it had got me tearing my hair out over here!

  2. #2
    Senior Member problemchild's Avatar
    Join Date
    Jul 2002
    Posts
    551
    What Linux distribution are you using, and what version of bastille?
    Do what you want with the girl, but leave me alone!

  3. #3
    Senior Member
    Join Date
    Feb 2002
    Posts
    130
    Sorry, looking at the monitor for all this time has obviously melted my brain, lol. I am using Mandrake 8.2 , and the version of Bastille that came with it which I believe is 1.2.0-5mdk

  4. #4
    Senior Member problemchild's Avatar
    Join Date
    Jul 2002
    Posts
    551
    Hmmmm... well, the first thing that jumps out at me is that there isn't a runlevel 36.

    Runlevels 3 and 5 determine whether you start up with a graphical or console login, but otherwise are the same. Runlevel 6 is the shutdown runlevel. So I'm not sure what you're seeing, but I'm pretty sure it isn't runlevel 36. It sounds like bastille is trying to start at bootup but can't. Did you select the start at boot option when you answered the questions?

    Also, are you sure you have all of the bastille rpms installed? By default, Mandrake doesn't install all of bastille. There are about 4 or 5 bastille packages total. Be sure you have bastille-tk-modules installed and call the script from a command line in XFree with InteractiveBastille.
    Do what you want with the girl, but leave me alone!

  5. #5
    Senior Member
    Join Date
    Oct 2001
    Posts
    638
    Try the serviceconf command. It's a GUI tool that allows you to control what services are started at run time. See if you can change the runlevel with the menu at the top. Otherwise you're going to have to go digging through your /etc/rc.d and /etc/xinetd.d directories to find the cause of the problem.
    OpenBSD - The proactively secure operating system.

  6. #6
    Senior Member
    Join Date
    Feb 2002
    Posts
    130
    problemchild, I have already been told, much to my embarrassment that run levels don't go even close to 36, told you my eyes were cracking under the strain of looking at the monitor that long,lol. I did select start at boot, and on furhter investigation it seems that it isn't starting (shown in the GUI and using the service command) just can't work out why it isn't starting. I have checked the options and it does show that Bastille should be started on boot.I am pretty sure that I have installed all of the packages and I set all of the settings using InterctiveBastille. I will check all the packages again just to make sure. Bastille does seem to be editing the IP Tables though, even though I can't make toal sense of them, think some more reading is required there.

    smirc, I have tried to use that command and it doesn't seem to be recognised, closet thing I could find was linuxconf, this lets me change what starts at boot time, bastille is down as automatic but like I said, just hasn't actually started, the plot thickens, lol.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •