View Poll Results: Are Antipoints getting out of control?

1. You may not vote on this poll
  • Yes! This is ridiculous!

    1 100.00%
  • No, you\'re just a pansy.

    0 0%
  • I don\'t know/Refused to Answer

    0 0%
Results 1 to 4 of 4

Thread: PCI Modem (Sorry, This Won't help if you have a Modem emulator{Win-modem})

  1. #1
    Junior Member
    Join Date
    Oct 2001

    Post PCI Modem (Sorry, This Won't help if you have a Modem emulator{Win-modem})

    I have seen many pages written for the modem and its installation but they mainly cover the ISA modems.
    This is for the PCI Modem. Now if you are looking here because have a Win-modem I'm sorry, But i cant
    help you.
    Because todays machines are using pci boards and ISA is a thing of the past, I have written this
    in hopes of helping a few souls out thier that need it. I know tht Highspeed access is the rage, and many
    think that OMG your still on a Dialup, get High Speed Access (HSA). Well this is not an option for many so
    the tried and true moden is the only way.
    Most other tutorials will tell you that PCI wont work. Wrong! There are several True modems out
    there that do. The Action-Tec Call Waiting Modem and the US Robotics 56k PCI Modem are 2 that I have
    used personaly that work just great. With that said, the following instructions are based on those 2 modems.

    The best thing to do is to read the box tha the modem comes in to make sure that its NOT a Modem-Emulator
    or the so called Win-modem. On to the Nitty Gritty.

    It is assumed that you have already installed the hardware as this paper is not intended as to tell you how to
    do that. It is also assumed that you Kernel has serial support, and PPPD as well as a communication program
    such as Mini-com

    Log onto linux and start a terminal session and SU as root

    The modem is going to be configured based on the following files that are assumed to be on the system
    dev/ttySx or dev/cuax

    If by chance they are not there you can add them by this command:
    cd dev
    ./MAKEDEV ttySx (x=port number) ie: ./makedev ttsS4

    on open Linux there is no make DEV so the command is:
    mknod /dev/ttyS4 c 4 68
    mknod/dev/tcua4 c 5 60
    (note that in kernels 2.2.x and later the cuax have been depricated)

    Next step is to create a few symbolic links

    ln -s /dev/ttyS4 /dev/modem (this creates a symbolic link from the dev ttyS4 to dev modem)
    chmod 666 /dev/ttyS4
    chmod 666 /dev/modem

    Now lets determine what communications por the modem is on
    cat /proc/pci

    Look at the output and find the modem
    you might see something like this:

    Bus 1, device 8, function 0:
    Serial controller: US Robotics/3Com 56K FaxModem Model 5610 (rev 1).
    IRQ 10.
    I/O at 0xecb8 [0xecbf].

    Write down the first input/output (I/O) and the IRQ
    now type in this command:
    setserial /dev/modem uart 16550a port <your value> irq <your value>

    now try it out in mini-com. If it worked add the above command to the following file two times. as such:

    in the file /etc/rc.d at the last line
    setserial /dev/modem uart 16550a port <your value> irq <your value>
    setserial /dev/modem uart 16550a port <your value> irq <your value>

    This will insure that the modem is set every time that you boot!

    Now lets set up the PPP

    Is assumed that you have an ISP and valid account

    you will need:
    User name (login) and password
    the Dial up Telephone number
    the IP address thats been assigned (this doesnt apply if your ISP uses a Dynamic IP as Most Do)
    The Dynamic Name Server (DNS) addresses (you need at least one i order to translate from
    URL names like www.antionlind to the IPV4 IPV6 URL )

    PPP comes with some scripts that are alread made that just need to be edited and moved a bit.
    you can find them on MOST systems at
    /usr/share/doc/ppp-2.x.x (depending on you version of ppp)

    type in the following editing to fit your system

    cp /usr/share/doc/ppp-2.4.1/scripts/ppp-* /etc/ppp

    now cd to the /etc/ppp dir and open up in a text editor the following file


    make the changes in the username password telephone numbers and such
    also at the bottom of the file change the line that reada /dev/ttyS0 to the tty that you system uses
    change the value 38400 to 115200. Save and close

    Open up the ppp-on-dialer in an editor

    change the setting afer TIMEOUT from 30 to 60
    Change the line that reads
    exec chat -v to
    exec /usr/sbin/chat -v
    save and close

    Open up /etc/ppp/options and make SURE that there is a line that says LOCK
    This prevents other processes from accessing the modem while in use. Save and Close

    Now lets set the permissions

    Make sure that your in /etc/ppp as root
    Set the permissions for the scripts as follows

    chmod +x ppp-o*

    Now the passowrd is stored Unencrypted (yeah, I know thats not the best way, but hey, it works) so we are
    going to se the permissions on that file to 711 (read/write/execute for the owner and execute-only for everyone

    chmod 711 ppp-on
    chown root ppp-on
    chgrp root ppp-on

    now open up /etc/resolv.conf and add in the DNS address that was provided by your ISP

    Lets make another Symbolic link for the scripts

    ln -s /etc/ppp/ppp-off
    ln -s /etc/ppp/ppp-off

    Thing should be up and working

    If you Use a GUI Like X-server and KDE or GNOME you can edit the dialup programs from the GUI
    interface and in a few moments be surfing the net to you hearts delight.

    Note in KDE KPPP doenst have an entry for DEV above ttyS3 so make sure that you use /dev/modem as we
    have already set the link for it

    Hoped this helped and happy surfing.

  2. #2
    Junior Member
    Join Date
    Sep 2003


    With the WAC Server running on some IP adress (feel free to do it to your own PC),
    connect to the ip on port 21 or telnet. To connect to yourself, the IP is
    Note: I have the new telnet, here is a screen shot

    For me, to connect to an IP is (xxx is ip) o xxx.xx.x.xx
    This is what it look slike to me after I connect to my WAC Server:

    Welcome to WAC Server 1.4 Build 0725. (C) Foxit Software, 2002-2003
    Evaluation Version. Maximum 2 users.
    Host: XXXXXX, OS: Windows XP

    Please use your Windows username and password to logon.

    Username: Xxxxxx
    Password: ****

    If all goes right, something like the next screenshot should pop up...

    From there, act like it was your own machine. Its quite easy to lean and fun.

    Note:You dont need to use telnet, you might have a program called Terminal. It's like telnet, only
    bigger font. Try it and see if you like it. It is located in...
    C:\Program Files\QPC\QVTNet\bin\Term.exe.
    I might just put it up on the page later on... But I think telnet is better.

  3. #3
    Senior Member
    Join Date
    Oct 2001
    Yeah, except telnet sucks now...

    SSH FOR LIFE!!!@!!111
    ...This Space For Rent.


  4. #4
    Senior Member nihil's Avatar
    Join Date
    Jul 2003
    United Kingdom: Bridlington

    If you bump an old thread up, please post something to indicate why you have done it?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts