FreeBSD - help
Results 1 to 6 of 6

Thread: FreeBSD - help

  1. #1
    Junior Member
    Join Date
    Oct 2002

    FreeBSD - help

    Hi there:

    Im using FreeBSD with kde3 and Gnome, for now..and im having a big problem, I try to connect as my user account and it disconnects quickly. BUT in my root account its connect and log on just fine to my ISP. I wonder whats happening. If someone knows something please let me know..


  2. #2
    Join Date
    Sep 2002
    Maybe permissions have been set for it not to logon or not to connect to the net? I'm not quite sure, seem's kind of weird to me, but I think maybe it's a permissions thing. Login as root and change that user's permissions/edit them. Hope I helped!

  3. #3
    Since we already have a FreeBSD post going....

    I run FTPD on my FreeBSD 4.6 box and need to change the port # it listens on but how do you do it?

  4. #4
    Originally posted here by Ratman2
    Since we already have a FreeBSD post going....

    I run FTPD on my FreeBSD 4.6 box and need to change the port # it listens on but how do you do it?
    Ok got around that problem (ISP was blocking port 21) but NOW you can connect but users can't get directory listings.... if anybody wants to try and help me connect to with a username and password of mp3

  5. #5
    Senior Member
    Join Date
    Apr 2002
    tux : how are you connecting? Standard dial up? PPP? More details on how you are connecting as root would be nice. Is there any software that you are trying to use to aid you in this? I don't work much with dial up, but with more information, I can probably help. As Common_Exploit has stated, yours is likely a permissions issue.

    Ratman : You can easily change the port most of your services are running on by modifying /etc/services

    typically, you look at it and you will see something along the lines of this :

    rtmp              1/ddp    #Routing Table Maintenance Protocol
    tcpmux            1/tcp    #TCP Port Service Multiplexer
    tcpmux            1/udp    #TCP Port Service Multiplexer
    nbp               2/ddp    #Name Binding Protocol
    compressnet       2/tcp    #Management Utility
    compressnet       2/udp    #Management Utility
    compressnet       3/tcp    #Compression Process
    compressnet       3/udp    #Compression Process
    echo              4/ddp    #AppleTalk Echo Protocol
    rje               5/tcp    #Remote Job Entry
    rje               5/udp    #Remote Job Entry
    zip               6/ddp    #Zone Information Protocol
    echo              7/tcp
    echo              7/udp
    discard           9/tcp    sink null
    discard           9/udp    sink null
    systat           11/tcp    users        #Active Users
    systat           11/udp    users        #Active Users
    daytime          13/tcp
    daytime          13/udp
    qotd             17/tcp    quote        #Quote of the Day
    qotd             17/udp    quote        #Quote of the Day
    msp              18/tcp    #Message Send Protocol
    msp              18/udp    #Message Send Protocol
    chargen          19/tcp    ttytst source        #Character Generator
    chargen          19/udp    ttytst source        #Character Generator
    ftp-data         20/tcp    #File Transfer [Default Data]
    ftp-data         20/udp    #File Transfer [Default Data]
    ftp              21/tcp    #File Transfer [Control]
    ftp              21/udp    #File Transfer [Control]
    ssh              22/tcp    #Secure Shell Login
    ssh              22/udp    #Secure Shell Login
    smtp            25/tcp     #Simple Mail Transfer Protocol
    smtp            25/udp    #Simple Mail Transfer Protocol
    Change the numerical value next to the service you would like to use and make sure that if you change it to a value that is already in use on this list that you comment out (using # at the beginning of the line) the other service that is bound to that value you are assigning.
    for example, moving ftp services to port 25 :
    ftp               25/tcp  #File Transfer Protocol
    ftp               25/udp #File Transfer Protocol
    ssh              22/tcp  #Secure Shell Login
    ssh              22/udp #secure Shell Login
    #smtp           25/tcp  #Simple Mail Transfer Protocol
    #smtp           25/udp #Simple Mail Transfer Protocol
    I don't recommend moving it to another typically assigned port like this, but you are free to do is you like and if you aren't using the service normally used on that port it's not likely to be harmfull with proper firewalling.

    Restart the service and all should be well. If in doubt on how to restart the service, then use the fast boot by using "fastboot" as root. The system will restart the service on boot.

    Hope this helps.

    I should let you know right away that you don't want to completely disable the smtp services. You are using them possibly without even knowing it. If you get reporting done to your root account to include disk usage, ipfw or other firewalling stats, file permissions changes, etc, disabling smtp services will disable the reporting and /var/log/maillog will show constant mail delivery failures from localhost to root. You may not care about this, but to keep yourself secure it is wise to leave it alone.
    \"I believe that you can reach the point where there is no longer any difference between developing the habit of pretending to believe and developing the habit of believing.\"

  6. #6
    Junior Member
    Join Date
    Oct 2002

    Thumbs up

    Oh well, i fixed the problemi was using KPPP, but i edited /etc/ppp.conf and add my login and auth key. AT console typed :

    # ppp <isp name>
    # dial <isp name>

    Its connected just fine..Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts