Help! PLEASE!
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Help! PLEASE!

  1. #1
    Developer Extraordinar
    Join Date
    Jul 2002
    Location
    Internets
    Posts
    571

    Help! PLEASE!

    Ok, here's my problem. I installed PHP-Nuke on my server and I also had this problem with InvisionBoards Anyways here it is...
    The users dosn't get their confermation e-mail. And I cannot snet out newsletters. Also When I try to sned out mass-mail to all my users in InvisionBoards I get this problem also.


    Quote from FeedBack on PHP-NUKE
    Warning: Failed to connect to mailserver, verify your "SMTP" setting in php.ini in c:\apache\htdocs\unerror\html\modules\Feedback\index.php on line 79


    Mail has been sent!


    Thank you for contacting us
    I donno what do to. :|
    Come to UnError.com

  2. #2
    King Arana: Super Moderator
    Join Date
    Oct 2002
    Posts
    4,055
    It appears that you forgot to add a little php code to your apache webserver to connect to the mailserver. I'm not exactly a php wizard, but it appears to be that problem, that no mailserver was specified or entered into the code. Either that, or there was a mistake, and it says it was on line 79. Check it out and see if you didn't add something in, or did add something not needed.
    Space For Rent.. =]

  3. #3
    Developer Extraordinar
    Join Date
    Jul 2002
    Location
    Internets
    Posts
    571
    I checked line 79 in the file it told me to. It says...
    mail($to, $subject, $msg, $mailheaders);
    I didn't edit this file at all....

    MB
    Come to UnError.com

  4. #4
    King Arana: Super Moderator
    Join Date
    Oct 2002
    Posts
    4,055
    From what I believe, there should be a $send code in there. I can be wrong, but I think it could be either $send or $connect. If I'm wrong, I'm sorry, Im just trying to help.
    Space For Rent.. =]

  5. #5
    Developer Extraordinar
    Join Date
    Jul 2002
    Location
    Internets
    Posts
    571
    I donno. I'm not PHP wiz either. I didn't edit the code at all. I used it as it came. If there is anything need to do to get it to work someone please help me..
    Come to UnError.com

  6. #6
    GreekGoddess
    Guest
    Open your configuration file, or wherever you need to enter your host mail data and make sure all settings are correct. If you don't have a specific user, try localhost and see if that works. You can find this information wherever your mail is hosted.

  7. #7
    Member
    Join Date
    Jul 2001
    Posts
    32
    The error is not in line 79. The mail command just tries to send the mail to the specific address $to with the message body $msg and the subject $subject and possibly additional headers. All these variables are gathered somewhere else in the script and need input from the current visitor. You need to configure your mail settings as GreekGoddess told. I think that the user, with which you are running the script (index.php) will appear as sender of the mail and should have access to your mail server. And of course your computer should have access to that server as well.

  8. #8
    Developer Extraordinar
    Join Date
    Jul 2002
    Location
    Internets
    Posts
    571
    I don't understand... I'm not a whiz at coding sites.... Can you please explain it in simple terms, and how to do it, if you can. Or PM me or what ever.
    Thanks in advance

    MB

    EDIT: All my mail setting are correct in the sites them selves I think...
    Come to UnError.com

  9. #9
    Junior Member
    Join Date
    Oct 2002
    Posts
    7
    hi, microburn i was wondering what is invisionboards??
    if you can\'t wear the skin of a lion wear the skin of a fox

  10. #10
    GreekGoddess
    Guest
    Okay, you usually have two options from your virtual control panel, let's take PHPNuke for example, go to your administrative configuration options.

    You should see two choices, either e-mail via boards or through SMTP. If you choose SMTP, you have to make sure that all the data correlates with your SMTP account, or you will receive an error, oftentimes using localhost as your username with no password solves this. If it's still not working, try to enable e-mail via board.

    It will usually look something like this: (This is the setup for PHPbb)

    Use SMTP Server for email:

    Say yes if you want or have to send email via a named server instead of the local mail function: Yes or No

    SMTP Server Address

    SMTP Username
    Only enter a username if your smtp server requires it

    SMTP Password
    Only enter a password if your smtp server requires it

    (I use host.sk and localhost is what I use, and you would put that under SMTP Server Address.)
    ---------------------------------------------------
    ---------------------------------------------------

    Primordial_Ooze, Invision Board is a free open source forum that you can download at:
    http://www.invisionboard.com/


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •