sending mail localy
Results 1 to 7 of 7

Thread: sending mail localy

  1. #1
    Senior Member
    Join Date
    Jun 2002
    Posts
    148

    sending mail localy

    I seem to be missing something. I installed and configured a mail server on one of my computers. I then downloaded a mail client called AK-Mail because I dont like Outlook Express. I set up an acount in the mail client and one in my mail server. I set it up to only alow local users to relay since I dont want spammers useing my mail system.

    Ak-Mail clicnt has a log feature:

    220 [24.101.0.0] My Mail Server/v5.01a SMTP/ESMTP server ready.
    SMTP: 18:35:05 [tx] HELO localhost
    SMTP: 18:35:05 [rx] 250 [24.101.0.0] Hi there, localhost.
    SMTP: 18:35:09 [tx] MAIL FROM:<admin@localhost>
    SMTP: 18:35:09 [rx] 250 Sender OK - send RCPTs.
    SMTP: 18:35:09 [tx] RCPT TO:<admin@localhost>
    SMTP: 18:35:10 [rx] 553 We do not relay non-local mail,

    This may be a silly question but how can I make my mail server know that I am a local user and I can relay?

    This was all done from the same computer. Both the client and server exist on the same computer it was sent from. Even if I try to use telnet, I still get the same error. How can I make myself local to my sever so as it alows me to send and recieve mail?
    In snatches, they learn something of the wisdom
    which is of good, and more of the mere knowledge which is of evil. But must I know what must not come, for I shale become those of knowledgedome. Peace~

  2. #2
    Senior Member
    Join Date
    Apr 2002
    Posts
    889
    Check your email client port, usually ligit mail is over port 25, since you know the port manually you may need to config the client to check the same port number. Keep 553 closed and since I do not know the server OS just a stab in the dark here, but usually ligit traffic is over standard ports. Also consider closing port 53 a real common relay channel.
    I believe that one of the characteristics of the human race - possibly the one that is primarily responsible for its course of evolution - is that it has grown by creatively responding to failure.- Glen Seaborg

  3. #3
    Senior Member roswell1329's Avatar
    Join Date
    Jan 2002
    Posts
    670
    Yaya. What Palemoon said. Most clients will default to send on port 25 and receive on port 110. If you configured your SMTP server to run on a different port, you'll likely confuse the hell out of most default mail clients.
    /* You are not expected to understand this. */

  4. #4
    Senior Member
    Join Date
    Nov 2001
    Posts
    4,786
    there must be a place to enter the name of the domain its in. if its not inside the domain as it sees it, its forign. Here it looks like the mail server dosn't know its localhost. You could of course allow relay and set the authentication to be the same as for pop. this should prevent spammers.

    if im not mistaken, 250 and 553 are the codes for the messages being displayed and do not relate to port numbers.
    Bukhari:V3B48N826 “The Prophet said, ‘Isn’t the witness of a woman equal to half of that of a man?’ The women said, ‘Yes.’ He said, ‘This is because of the deficiency of a woman’s mind.’”

  5. #5
    Senior Member
    Join Date
    Jul 2002
    Posts
    339
    if im not mistaken, 250 and 553 are the codes for the messages being displayed and do not relate to port numbers.
    Yes, they are. Anyone care to read the RFC?


    COMMAND-REPLY SEQUENCES

    Each command is listed with its possible replies. The prefixes
    used before the possible replies are "P" for preliminary (not
    used in SMTP), "I" for intermediate, "S" for success, "F" for
    failure, and "E" for error. The 421 reply (service not
    available, closing transmission channel) may be given to any
    command if the SMTP-receiver knows it must shut down. This
    listing forms the basis for the State Diagrams in Section 4.4.

    CONNECTION ESTABLISHMENT
    S: 220
    F: 421
    HELO
    S: 250
    E: 500, 501, 504, 421
    MAIL
    S: 250
    F: 552, 451, 452
    E: 500, 501, 421
    RCPT
    S: 250, 251
    F: 550, 551, 552, 553, 450, 451, 452
    E: 500, 501, 503, 421
    DATA
    I: 354 -> data -> S: 250
    F: 552, 554, 451, 452
    F: 451, 554
    E: 500, 501, 503, 421
    ...
    ...

    4.2.2. NUMERIC ORDER LIST OF REPLY CODES
    ...
    ...
    500 Syntax error, command unrecognized
    [This may include errors such as command line too long]
    501 Syntax error in parameters or arguments
    502 Command not implemented
    503 Bad sequence of commands
    504 Command parameter not implemented
    550 Requested action not taken: mailbox unavailable
    [E.g., mailbox not found, no access]
    551 User not local; please try <forward-path>
    552 Requested mail action aborted: exceeded storage allocation
    553 Requested action not taken: mailbox name not allowed
    [E.g., mailbox syntax incorrect]
    554 Transaction failed



    As Tedob1 said, the mail server doesn't know its localhost. You should be able to set it somewhere. Which mail server software are you using?

    Peace always,
    <jdenny>
    Always listen to experts. They\'ll tell you what can\'t be done and why. Then go and do it. -- Robert Heinlein
    I\'m basically a very lazy person who likes to get credit for things other people actually do. -- Linus Torvalds


  6. #6
    Senior Member
    Join Date
    Jan 2002
    Posts
    1,207
    The SMTP server will have in its config a list of local domains, and a list of domains it relays for. You need to put your local mail domains in both.

    It may also have a access list which tells it that host with particular IP addresses are allowed to relay. Put yourself in there too. If you put everyone in the relay allow list, you will quickly find spammers using your box as a spam relay (and then your ISP will ban you once they find out).

    Seeing as you haven't told us what mail server it is, I cannot help you with this particular configuration, but on qmail,

    The local domains is in /var/qmail/control/locals I think
    The relay domains is in /var/qmail/control/rcpt-hosts
    The allows relays work weirdly and are controlled via /etc/hosts.allow

    Cheers

  7. #7
    Senior Member
    Join Date
    Jun 2002
    Posts
    148
    A big thank you to everyone who responded. Useing the sugestion on telling my mail server that everything for localhost is regarded as local I was able to resolve the problem.

    That section of my configuration was found in the Configuration menu> Mercury cor Module configuration> localdomains Tab where I had to add localhost to the list. This solved the problem.

    It was asked what server software I was useing, I am useing a Mail Transport System called Mercury/32 for Win32 and NetWare Systems v3.31 (Not the latest version, I will update soon)

    However since this post, I decided against the AK-Mail email client for sending and recieveing my mail, instead I downloaded Pegasus Mail which is the recomended client to use with Mercury. You may download the latest versions of both Mercury MTS and Pegasus Mail for Windows systems from http://www.pmail.com/downloads_nz_t.htm

    I assume you could easily use Outlook express for mail retrieval and sending too.
    In snatches, they learn something of the wisdom
    which is of good, and more of the mere knowledge which is of evil. But must I know what must not come, for I shale become those of knowledgedome. Peace~

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •