xf86 turmoil
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: xf86 turmoil

  1. #1
    Junior Member
    Join Date
    Nov 2002
    Posts
    10

    Angry xf86 turmoil

    ok i installed slack and logged in, selected a win manager then "startx" but i get a fatal server error as follows: "screens not found." can anyone offer a remedy for this? TIA!
    keepin it jesus in 2002

  2. #2
    Senior Member
    Join Date
    Apr 2002
    Posts
    317
    What version of X did it install? I had the same error for a pretty substantial amount of time when I didn't have it configured correctly for my hardware.

    What I would recommend is as follows : (if you have version 4.2.0 or later, then jump to step 3)
    1. get the latest version of X. See the details on the latest releases http://www.xfree86.org. It is free for download at many locations. I have always had good luck on the mirror ftp.rge.com. [you are likely to be asking why get the latest version, and I say because it is easier to configure. You'll see in a bit.]
    2. once you have the latest version, run "sh ./Xinstall.sh" and install the software as needed.
    3. once the software has installed, you will want to run "XFree86 -configure" and this will create the file /root/XF86Conf.new and you merely need to move it to the correct location for your system. (This is the reason I recommend getting the latest version, it will probe and configure for system and you can move the file to whatever location it belongs.)
    4. Ensure you have the file $home/.xinitrc and that it points to your window manager of choice. Sample of mine is as follows :
    Code:
    exec enlightenment
    I believe the commonly used lines for the file are gnome-session or startkde for Gnome and KDE respectively.

    Hope this helps and best of luck.
    Regards.

    [edit]
    I should let you know that the commands and locations of files vary based on distro and *nix variation. Most of the information I have provided is more oriented to the BSD's, but all the concepts are the same with minor modifications. I believe that this is likely to be of value to you as well. ProblemChild provides some Linux distro specific details.
    \"I believe that you can reach the point where there is no longer any difference between developing the habit of pretending to believe and developing the habit of believing.\"


  3. #3
    Senior Member problemchild's Avatar
    Join Date
    Jul 2002
    Posts
    551
    It sounds suspiciously like X hasn't been configured for your adapter and monitor yet. Have you run xf86config or another setup tool?

    Check and see that /etc/X11/XF86Config is in place and properly configured. If it isn't, that's your problem and xf86config will take care of it.
    Do what you want with the girl, but leave me alone!

  4. #4
    Junior Member
    Join Date
    Nov 2002
    Posts
    10
    Chefer:well i checked and slack 8.1 has the latest distro for x but i followed the instructions and still no such luck. however a wealth of gratitude is extended to you for the commands i needed those.

    problemchild: yes several times i have run xf86config. the odd thing is i cant get to /etc/X11/XF86config. i get a "permission denied" prompt.

    nonettheless im gonna be at it all night so feel free to drop a line here netime cuz ill be here!
    keepin it jesus in 2002

  5. #5
    Senior Member
    Join Date
    Aug 2002
    Posts
    508
    If you've got "permission denied" when you turn on your slack..do like what I've done to my slack 8.1(maybe works for you)

    Login : root
    Password:

    untill you've got #<< and then # vi /etc/X11/XF86Config

    You will see your X configuration and look at your "input device for mouse " ...find protocol "(name of mouse)"<<< changed to "auto".

    check your video card configuration ..if you already got the right one..
    go to section "screen":
    Identifier " A"
    Device "B"
    Monitor "monitor"
    DefaultColorDepth 24<<<<,I added this line

    and the the last thing go to subsection "Display":
    Depth 24
    Modes "1024x768"<<<< I edit to this line

    That's it just typed :wq to save your edit

    and then typed startx

    That's works for my slack 8.1...Hope this helps..

    Upss sorry BTW I'm not using slack any more
    Not an image or image does not exist!
    Not an image or image does not exist!

  6. #6
    Senior Member problemchild's Avatar
    Join Date
    Jul 2002
    Posts
    551
    Which user are you working as when you get the error? Can you start X as root but not as a user? If so, it could be a permissions problem on your /tmp directory or something. That happened to me one time, and I just about pulled my hair out trying to figure it out.
    Do what you want with the girl, but leave me alone!

  7. #7
    Senior Member
    Join Date
    Aug 2002
    Posts
    508
    I 've reinstall again my slack ware and try to follow what I've done ..Ithink will work for you :
    Login : root
    Password:

    untill you've got #<< and then # vi /etc/X11/XF86Config

    You will see your X configuration and look at your "input device for mouse " ...find protocol "(name of mouse)"<<< changed to "auto".

    check your video card configuration ..if you already got the right one..
    go to section "screen":
    Identifier " A"
    Device "B"
    Monitor "monitor"
    DefaultColorDepth 24<<<<,I added this line

    and the the last thing go to subsection "Display":
    Depth 24
    Modes "1024x768"<<<< I edit to this line

    That's it just typed :wq to save your edit
    # cp XF86Config.new /etc/X11/XF86Config <<<I forgot this one and then "enter'

    # startx

    And you will see your slack

    cheerss

    ohh BTW you can edit your "display modes" from 1024x768 to 800x600 or 640x480 ..you can try it..
    Not an image or image does not exist!
    Not an image or image does not exist!

  8. #8
    Leftie Linux Lover the_JinX's Avatar
    Join Date
    Nov 2001
    Location
    Beverwijk Netherlands
    Posts
    2,535
    Why not just as problemchild said, (as root) run xf86config the setup script will ask you some questions about your input (mouse and keyboard) and output (videocard and monitor) hardware and setup the /etc/X11/XF86Config file for you !!

    then running startx should get you up and running,

    running kdm starts the standard KDE login manager, you can also add /opt/kde/bin/kdm to your /etc/rc.d/rc.local wich is the last script ran at boot time, then you box starts with a graphical login screen

    hope it helps
    ASCII stupid question, get a stupid ANSI.
    When in Russia, pet a PETSCII.

    Get your ass over to SLAYRadio the best station for C64 Remixes !

  9. #9
    Senior Member
    Join Date
    Aug 2002
    Posts
    508
    yupe ... That's what I wrote typed as "root" on the beginning of my replied..(I've got same problem and my problem solved)

    I've got same problem as "word"<<<< error ..screen not found..even I run as root and run xf86conf but after I edit my xf86con like what I wrote... when I typed startx my slack turn up nicely..
    Not an image or image does not exist!
    Not an image or image does not exist!

  10. #10
    Junior Member
    Join Date
    Nov 2002
    Posts
    10
    hey sweet, um i made those changes but how do i leave that screen, save my changes, and get back to #?
    keepin it jesus in 2002

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides