Hi guys, I'm not expert yet on *nix(I'm still learning..)...but I've got this trick...when I tried to installed BSD on laptops;

I assume you've already done your installation for BSD, If you haven't done yet..you can look at here too (I've read tutorial by ratman http://www.antionline.com/showthread...hreadid=223701 ).

Installation BSD on laptop is very tricky some times....and after you've done installation and then when you typed "startx" usually end up with "error screen no found".
So I decided to wrote this tricks and I hope this helps:

1. If you haven't got XFree 4.x get it from www.xfree86.org
2. After you've got XFree 4.x..this is what I've done:

-using Vi to edit vi /etc/X11/XF86Conf (I just pick the section I've edited I assuming you don't have problem with your "probe")

Section "ServerFlags"
AllowMouseOpenFail# allows the server to start up even if the mouse doesn't work<<<I added this line (but optional)
Section "InputDevice"
Identifier "mouse"
Driver "mouse"
Option "Device" "/dev/gpmdata"
Option "Protocol" "IntelliMouse"<<<<<this is very important part if your mouse not working properly..your X won't start I edit this to "auto" specially if your mousse jumping around like popcorn or not working propely
Option "Emulate3Buttons" "true" <<< I added this line


Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-107 <<<< I added this line(basicly you can edit to your one maybe 30-70...etc)
VertRefresh 48-120<<<< I added this line


Section "Screen"
Identifier " Screen0"
Device " Card0"
Monitor " Monitor0"
DefaultColorDepth 24 <<< I added this line

SubSection "Display"
Depth 24
Modes "1024x768" "<<<< I added this line (You can edit to 800x600 or 640x480)


# end of XF86Config

And then just typed :wq to save your edit...and then you can start to typed "startx"

For Open BSD before you edit /etc/X11/XF86Conf do this one first:
#XFree86 -configure
#XFree86 -xf86config XF86Config.new <<<<to test your configuration..after you see your black and grey grid and X mouse cursor appears typed this:
#vi XF86Config.new <<and then next step is..look at my tricks for XF86Config editing above
#cp XF86Config.new /etc/X11/XF86Config <<<<the last part but important
And that's it you finished
BTW don't forget to log in as "root"

PS : -I tried Free BSD 4.5,4.6,4.7 and 5 current and also Open BSD 3.1,3.2 on Laptop Toshiba satellite 1800 series,IBM thinkpad 600, and SONY VAIO..(I hope working for other laptop too)and it works..this trick somehow..