Upgrading Linux kernel 2.5
Results 1 to 3 of 3

Thread: Upgrading Linux kernel 2.5

  1. #1
    Senior Member
    Join Date
    Aug 2002
    Posts
    508

    Upgrading Linux kernel 2.5

    Hi guys....I'had upgrade my kernel 2.4.19 to kernel 2.4.20 without problem.
    But I tried to upgrading my kernel 2.4.19 to kernel 2.5.51 (or 2.5.52) always end up with 'error need QT '.
    So I 've been searching for QT but I couldn't find "free QT" (I'm looking at site http://www.trolltech.com/)
    Anyone knows where I can get free QT to down load?
    Or Anyone knows how to solve my problem on kernel 2.5.51/52?

    Thanks for your help


    ps: if I posted this thread in wrong forum ...sorry..
    Not an image or image does not exist!
    Not an image or image does not exist!

  2. #2
    Senior Member
    Join Date
    Jan 2002
    Posts
    1,207
    I would recommend you didn't upgrade to 2.5

    If you don't know how to get the necessary libraries to run the new graphical config tool (or indeed know how to run the non-graphical config tool), then you probably don't want to be messing with 2.5.

    If you must run 2.5, do it on a separate disc (or machine) where you have *no* data that you remotely care about, and on a machine you don't mind crashing, failing to boot etc. Don't mount any local discs you care about read-write.

    2.5 is the unstable series. Currently it's passed its feature freeze, so theoretically it should be more stable now. I've built a few 2.5 kernels so far - about 50% didn't build and a few of the ones that didn't build didn't boot.

    In answer to your original question: you probably need to install the libqt2-devel package from your original distribution. Or it might be a later version. Or something. Anyway it should be included on your current distro if it's vaguely recent. If your current distro is out of date, don't attempt to build or install 2.5 as it may not work anyway.

  3. #3
    Senior Member
    Join Date
    Aug 2002
    Posts
    508
    Thanks for your replied slarty...

    The reason I tried to ugrade kernel 2.5 is just for testing (yupe I'm very sure kernel 2.5 is unstable ...I agreed with you)
    2.5 is the unstable series. Currently it's passed its feature freeze, so theoretically it should be more stable now. I've built a few 2.5 kernels so far - about 50% didn't build and a few of the ones that didn't build didn't boot.
    So you've already tried too.....mmmmm might be not going to be work for me..

    If you must run 2.5, do it on a separate disc (or machine) where you have *no* data that you remotely care about, and on a machine you don't mind crashing, failing to boot etc. Don't mount any local discs you care about read-write.
    Yupe ..I've got one box special if I wanna play around with Linux...so I don't mind if crashing my box..( it happened many times....well...mmmm that's part of my learning..*nix here..)

    In answer to your original question: you probably need to install the libqt2-devel package from your original distribution. Or it might be a later version. Or something. Anyway it should be included on your current distro if it's vaguely recent. If your current distro is out of date, don't attempt to build or install 2.5 as it may not work anyway.
    I'had built that kernel on current distro.....and the libqt2-devel already in it.
    I guess you alright slarty..maybe I shouldn't built kernel 2.5 (I can't wait for kernel 2.6 )..
    But I will try again today (all day ) to figure out this kernel....maybe I am lucky

    ps: I've been using non graphical tool ..to built kernel 2.5....I can't get xconfig cause I need QT
    Not an image or image does not exist!
    Not an image or image does not exist!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •