Cant connect to my apache server from remote machine
Results 1 to 3 of 3

Thread: Cant connect to my apache server from remote machine

  1. #1
    Join Date
    Dec 2001

    Cant connect to my apache server from remote machine


    I just installed Apache 2.0 on my Redhat 7.3 (2.4.19) system. I started my httpd and tryed to connect to it from http://localhost and it WILL connect. Then went into the httpd.conf file and changed the servername to "myipaddy" and made sure it was listening on port 80 and then tryed to connect to it from a remote machine and it wont connect i get a "THE PAGE CANNOT BE DISPLAYED".

    I UN-INSTALLED ipchains and lokkit firewall casue im running IPTABLES 1.2.7a But i have my rules in place that open port 80. I have tryed to run a PORT scan on the maching from a remote machine and it says NO PORTS OPEN. (i ran the port scan using IP TOOLS ver 2.08)

    I have also tryed to using tcpdump on the machine and then tryed to connect from a another machine to see if the kernel was dropping any packets and it wasnt. I can display the output.

    Here are my rules for iptables to open port 80
    if [ "$CONNECTION_TRACKING" = "1" ]; then
    iptables -A INPUT -i eth0 -p tcp \
    --sport 1024:65535 \
    -d "myipaddy" --dport 80 \
    -m state --state NEW -j ACCEPT

    iptables -A INPUT -i eth0 -p tcp \
    --sport 1024:65535 \
    -d myipaddy --dport 80 -j ACCEPT
    iptables -A OUTPUT -o eth0 -p tcp \
    -s myipaddy --sport 80 \
    --dport 1024:65535 -j ACCEPT

    Could there be something else that is dropping the packets on my machine or my ISP blocking it? Is there some way to test to see of there are? I know this isnt much to go on but anybody got some ideas.

    EDIT--> I have also tryed to make the httpd to listen on port 81 and still cant connect!

  2. #2
    Just a Virtualized Geek MrLinus's Avatar
    Join Date
    Sep 2001
    Redondo Beach, CA
    Hrmmm.. At this point it looks like you've got everything up and running (I am assuming that the daemon is running when you are attempting this? I know it's silly but sometimes we reboot and forget to restart it if we haven't made an rc script). So I'd say it's not your end but rather your ISP. It wouldn't surprise me if ISPs start blocking services they don't want running from their regular clients so as to discourage rogue web servers and such.
    Goodbye, Mittens (1992-2008). My pillow will be cold without your purring beside my head
    Extra! Extra! Get your FREE copy of Insight Newsletter||MsMittens' HomePage

  3. #3
    Senior Member
    Join Date
    Jan 2002
    Have you tried conncting from the LAN? Maybe your ISP blocks connections to port 80 themselves?

    Also because you may have errors in the firewall config, try just removing all ipchains rules altogether, then try.

    Get it working on a LAN, without the firewall, then make sure the firewall is working right, then try from elsewhere. The ISP may block all ports below 1024 or something if they're really paranoid, so try a high port number instead (8080 is popular)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts