Unable to read partition table
Results 1 to 4 of 4

Thread: Unable to read partition table

  1. #1
    Senior Member gore's Avatar
    Join Date
    Oct 2002

    Unable to read partition table

    Hey all, i have a question, as some of you know, from reading my journal, i had a problem after a format, i reformated and reinstalled Windows 98 SE and then wanted to change something and have a fresh start, so i did chkdsk, said it couldnt do it and i think it said use scandisk, and then i did fdisk/mbr, it said it couldnt so im like ok, so anyway, i went and put in the restore CD and shut down, smoked, turned the computer on, it started, and said it couldnt find my HD, this happened before when i had 2,000 with NTFS on here so i did what i did last time that fixed it and booted from a Regular Windows 98 SE CD rom and again it couldnt format, Windows 2,000 pro wouldnt format it either, even after deleting all partitions, (i had Suse Linux 8.1 Professional on there but took it off and had partition magic and boot magic goin before but had reformatted and taken them off) i tried booting with the partition magic CD after realising only Linux would install and partition magic said it was a bad partition or something but wouldnt format it, so i reinstalled Linux fresh from the DVD i booted from and then reset up everything in Linux, iv been noticing though that when i boot up, after it gets to the login screen (i use grub) it has a list of logs from the boot up, i noticed it saying "kernal couldnt read partition table" or somethin like that, everything works fine but im just wondering what this could be, any help would be greatly appreciated.

  2. #2
    Antionline Herpetologist
    Join Date
    Aug 2001
    A friend of mine had a similar problem once, except that only Win9x would install, her drive wouldn't format and no other OS worked. It turned out to be a hard disk problem. Sounds like the same thing to me. You probably have a bad sector at a crucial point (first few sectors) on your hard disk and the only thing you can do about it is to get a new one.
    Buy the Snakes of India book, support research and education (sorry the website has been discontinued)
    My blog: http://biology000.blogspot.com

  3. #3
    Senior Member
    Join Date
    Apr 2002
    gore you ahve *nix installed ? if use fdisk to see if that can read you're partition table make sure you are root and then just
    [root@localhost tutorials]# /sbin/fdisk -l

    Disk /dev/hda: 255 heads, 63 sectors, 3649 cylinders
    Units = cylinders of 16065 * 512 bytes

    Device Boot Start End Blocks Id System
    /dev/hda1 * 1 6 48163+ 83 Linux
    /dev/hda2 7 3584 28740285 83 Linux
    /dev/hda3 3585 3649 522112+ 82 Linux swap
    [root@localhost tutorials]#
    and you should se something like that if that dont work it might be what cgkanchi said a fecked hard drive
    By the sacred **** of the sacred psychedelic tibetan yeti ....We\'ll smoke the chinese out
    The 20th century pharoes have the slaves demanding work

  4. #4
    Join Date
    Mar 2003
    SuSe also has a good team of people so mailing them about this may help, also use the mailing lists for SuSe and see what you can find, hope you find the answer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts