Results 1 to 4 of 4

Thread: RH 8 probs

  1. #1
    Join Date
    Jan 2002

    RH 8 probs

    Hi Guys
    I am back to bug u with more problems of mine. Yesterday, I installed RH 8 on my system and so far my opinion abt it is " it sucks". Well, before I get into the intricacies of wht all I disliked abt it(which is a big lot, believe me) and invite a flame war, here are the probs and one general query:
    1) I can't seem to play any mp3s. Dbl clicking crashes Konqueror. Dragging and dropping in xmms doesn't work. Even when I try to add files using the add files or add directory button, the files don't get added. Whts more, many of the buttons in xmms don't seem to work.

    2) I can't find linuxconf anywhere. It wasn't included in the packages. I did a "install everything" to see whether I had missed to install it, but still it wasn't installed. Can I install it separately by downloading some package from the net.

    3) The usage of my swap space remains 0% all the time while that of my physical memory(192 MB) is almost 98%. I experienced this with other linux distros also. This despite I don't have any servers installed and only very few services run at startup and moreover, while booting, it shows "Enabling Swap Space [OK]".

    I install LILO on a separate boot disk instead of the MBR. Now, with RH 7.1 and MDK 9, it took only abt 5 mb of space on my boot disk (31 MB) but when I tried to install RH 8 it asked me to resize my boot disk to atleast 75 MB, which I did. But now when I see the disk usage, its only abt 10 MB. My question is if so less of disk is to be used then why does RH 8 demand for atleast 75 Meg boot disk space.

  2. #2
    Senior Member
    Join Date
    Jul 2001
    1. I have never tried playing MP3's so can't answer.
    2. Redhat did not include linuxconf in this distribution, you can get it at


    Seen some chatter that says it works very nicely with Redhat 8.0, although I have not tried it, and did not look very deep into the conversations.

    3. IIRC, and I am not 100% sure I do remember correctly, the linux kernel is very intense with its memory usage. If you open a browser, and notice, how it takes quite a long while to open it the first time. If you close it, and then open it again, it happens very fast. This is because the kernel maintains memory for that particular application until it needs the memory for something else. So, seeing a very high percentage of memory used (i.e. 98%) is not terribly unusual. Also, IIRC, the kernel does not like to use swap space unless it has to, as the access time for swap is much greater than the access time for physical memory. I would not be terribly concerned about this, unless of course you are noticing some severe performance issues.

    I have no idea why Redhat wants so much space, although I suppose if you were to compile several different kernels which you wanted to maintain all of them, you could start running into space issues on /boot.

  3. #3
    I just try to play some mp3 that were in a fat32 partition with the xmms and it didn't work i guessing it has to be the xmms but hey there are differents player. I use KDE and also use jukebox and it works you can download from here http://sourceforge.net/projects/kionjb/ or check for other alternatives
    \"Knowledge is Power\"

  4. #4
    Senior since the 3 dot era
    Join Date
    Nov 2001

    Angry give it some time

    1) It's normal that you can't play mp3's in RedHat 8.0 with xmms out of the box.
    This has to do with legal issues. RedHat was not allowed to add mp3 functionality in the xmms player bundled with RH8. You can get around this by downloading a patch. http://psyche.freshrpms.net/rpm.html?id=106

    2) Linuxconf isn't around anymore. It's obsolete so to speak... anyway if you really want to have control over you system, edit the config files yourself in /etc and you can easily change a lot of settings in the various available config tools in the gnome GUI.

    3) physical memory is not completly used, why should linux swap?

    about your last question -> yes the new lilo version that comes with RH8 only takes a fraction of the space that RH8 demands for the /boot . Perhaps this space is reserved to allow a various multi OS setup?

    So before you complain about your fresh OS -> look why some things are removed and how you can fix those. And besides it's only a 8.0 version.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts