Port 135?
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Port 135?

  1. #1
    Senior Member
    Join Date
    Dec 2002
    Posts
    275

    Exclamation Port 135?

    epmap 135/tcp DCE endpoint resolution . Everytime i go through and disable all of the services i dont want running, i go back and check through netstat -an, and i always find Tcp port 135 running does anyone know a way to manually close this port(or are you not supposed to) . I dont windows allows you to disable the RPC service though, only the RPC locator.

  2. #2

  3. #3
    AO übergeek phishphreek's Avatar
    Join Date
    Jan 2002
    Posts
    4,325
    The most obvious ways would be to just block it using a firewall.

    I believe that port 135 is used by messenger. Simply goto control panel, then admin. tools.
    go into services and disable the messanger service, and stop it.

    Here is a good explination of why you'd want to disable it.

    See if that port is still open... it shouldn't be.

    There is another way here. Though it is a bit more complicated...

  4. #4
    Senior Member
    Join Date
    Dec 2002
    Posts
    275
    I have already disabled messenger through services.msc. I should have mentioned in the previous post that i am using a firewall. I have already tried disabling this port through the registry >>HKEY_LOCAL_MACHINE>Software>Microsoft>OLE, and changing the EnableDCOM value to N, but its still showing up in netstat -an. That method is supposed to disable it. Im gonna try out the method in the link you posted phishphreek.

  5. #5
    Member
    Join Date
    Oct 2001
    Posts
    76
    Port 135 cannot be closed. The only way to do it is to install a firewall. If you got windows XP, just turn on the windows firewall, otherwise tiny personal firewall is good (and free), but needs a bit of configuring to get set up properly. Zone Alarm is also free, and needs hardly any configuration at all. There are other firewalls out there, just take your pick on which one you want to use.

    HTH

  6. #6
    Just a Virtualized Geek MrLinus's Avatar
    Join Date
    Sep 2001
    Location
    Redondo Beach, CA
    Posts
    7,324
    Beryllium9 said: Port 135 cannot be closed.

    For earlier products (NT, 98/95) I don't believe you can close port 135 although you can block it with a firewall (ZoneAlarm, Outpost, TinyFirewall are all good freeones). With the 2000/XP family of products I believe you can close down port 135 (and 137 and 139) by stopping the Messenger service.
    Goodbye, Mittens (1992-2008). My pillow will be cold without your purring beside my head
    Extra! Extra! Get your FREE copy of Insight Newsletter||MsMittens' HomePage

  7. #7
    Senior Member
    Join Date
    Apr 2002
    Posts
    634
    I am using XP and I have never been able to block the port 135 by another way than through a firewall.
    After I have done some search about it, I discovered that this port is used by Windows for some endpoints resolution. So, it's more than being simply related to messenger service.

    KC
    Life is boring. Play NetHack... --more--

  8. #8
    Just a Virtualized Geek MrLinus's Avatar
    Join Date
    Sep 2001
    Location
    Redondo Beach, CA
    Posts
    7,324
    Weird. I know the machines at work -- Windows XP Pro -- have 135/137/139 off. So somehow they did it. Perhaps a registry setting then.
    Goodbye, Mittens (1992-2008). My pillow will be cold without your purring beside my head
    Extra! Extra! Get your FREE copy of Insight Newsletter||MsMittens' HomePage

  9. #9
    Senior Member
    Join Date
    Mar 2003
    Posts
    170
    >Try this link it might have what your looking for.
    > http://www.securityspace.com/smysecu...t.html?repid=4
    >
    >Hope that helped.
    [glowpurple]NooNoo\'s [/glowpurple]

  10. #10
    Just a Virtualized Geek MrLinus's Avatar
    Join Date
    Sep 2001
    Location
    Redondo Beach, CA
    Posts
    7,324
    Goodbye, Mittens (1992-2008). My pillow will be cold without your purring beside my head
    Extra! Extra! Get your FREE copy of Insight Newsletter||MsMittens' HomePage

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •