XFree86 problem
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: XFree86 problem

  1. #1
    Junior Member
    Join Date
    Mar 2003
    Posts
    8

    XFree86 problem

    hi, I installed freebsd 4.7 but can't get x server to work. My box have an on-board video card.
    Still can't get x to work. Should I buy a video card? or should I install the new release of xfree86?

    Any help or suggestion would greatly be appreciated.

  2. #2
    Just Another Geek
    Join Date
    Jul 2002
    Location
    Rotterdam, Netherlands
    Posts
    3,403
    I'm running 4.7 with X4.3.0. What seems to be the problem?

    You could try running XFree86 -configure as root.

    from XFree86(1):

    -configure
    When this option is specified, the X server loads all video
    driver modules, probes for available hardware, and writes out
    an initial XF86Config(5) file based on what was detected. This
    option currently has some problems on some platforms, but in
    most cases it is a good way to bootstrap the configuration pro-
    cess. This option is only available when the server is run as
    root (i.e, with real-uid 0).

  3. #3
    Banned
    Join Date
    Jul 2001
    Posts
    264
    A little more information would be helpful don't you think...Like Make/Model of your onbord card. Distro of OS, version of X server. Error messages, etc.

  4. #4
    Just Another Geek
    Join Date
    Jul 2002
    Location
    Rotterdam, Netherlands
    Posts
    3,403
    Originally posted here by Quad
    A little more information would be helpful don't you think...Like Make/Model of your onbord card. Distro of OS, version of X server. Error messages, etc.
    I believe Distro of OS would be freebsd 4.7 but the rest would definitly help

  5. #5
    Senior Member
    Join Date
    Mar 2003
    Posts
    452
    Try the latest releast of the xfree86 server, I had a similar problem with Red Hat, and that seemed to fix my problem. For the longest time, there was no hardware support for my video card, updating to the latest release made everything easy, as it auto detected my card and I was on my way. Good luck!



    PuRe
    Like this post? Visit PuRe\'s Information Technology Community. We\'ve also got some kick ass Technology Forums. Shop for books and dvds on LiveWebShop.com

  6. #6
    Senior Member
    Join Date
    Oct 2001
    Posts
    186
    I have had this problem on slackware linux with onboard video also. My gigabyte k7 triton motherboard does not support linux and even with default vga configuration i could not get it to work correctly. It is onboard savagepro 4 and is listed but does not work. If i figure out a way to get mine running ill let you know and maybe what i have learned can help you.
    Ben Franklin said it best. \"They that can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety.\"

  7. #7
    Leftie Linux Lover the_JinX's Avatar
    Join Date
    Nov 2001
    Location
    Beverwijk Netherlands
    Posts
    2,535
    did you try enabeling a framebuffer device..

    Code:
    This generic interface should work with nearly all video cards (although
    not every card will support every resolution).  To use the Linux framebuffer
    console, you need to enable these kernel options:
    Using 'make menuconfig', in 'console drivers', enable:[*] VGA text console[*] Video mode selection support[*] Support for frame buffer devices (EXPERIMENTAL)[*] VESA VGA graphics console[*] Advanced low level driver options
      <*> 8 bpp packed pixels support
      <*> 16 bpp packed pixels support
      <*> 24 bpp packed pixels support
      <*> 32 bpp packed pixels support
      <*> VGA characters/attributes support[*] Select compiled-in fonts[*]   VGA 8x8 font[*]   VGA 8x16 font
    
    If you have a Matrox or ATI Mach64, you might try enabling the options having
    to do with those cards as well.  However, if the card is VESA compliant, you
    don't really need to (and it might cause problems, possibly)
    
    Next, if this file is not already named /etc/X11/XF86Config, make a copy
    with that name.  This file ships with the name XF86Config-fbdev to avoid
    overwriting an existing config file.
    
    To get the kernel to start in VESA framebuffer mode, you need to pass it
    a vga= init string at boot time.  For example, if you use LILO you'll
    probably find a vga=normal string in your /etc/lilo.conf.  If you edit that
    to one of the values in this table:
    
       Colours   640x480 800x600 1024x768 1280x1024 1600x1200
      --------+---------------------------------------------
      256     |   769     771      773      775       796
      32,768  |   784     787      790      793       797
      65,536  |   785     788      791      794       798
      16.8M   |   786     789      792      795       799
    
    
    ...such as this for 1024x768x64k:
    vga = 791
    and then reinstall LILO by running 'lilo' as root, then at the next boot
    Linux should start in a VESA framebuffer console mode.
    
    For more information on how to activate the Linux frame buffer, see
    /usr/src/linux/Documentation/fb/vesafb.txt.
    from slackware /etc/X11/XF86Config-fbdev
    ASCII stupid question, get a stupid ANSI.
    When in Russia, pet a PETSCII.

    Get your ass over to SLAYRadio the best station for C64 Remixes !

  8. #8
    Senior Member
    Join Date
    Aug 2002
    Posts
    508
    My box have an on-board video card.
    My old comp have on-board video card (S3 SAVAGE4) but I didn't get good X configuration even I've got S3 SAVAGE4 on the list of FreeBSD and what I did is I used "VESA" as video card. And this trick works for me somehow.

    Logged in as root :
    #xf86config

    And then when you have to choose video card ..pick "VESA" and choose your modes (800x600,1024x768,etc) save configuration and typed "startx"

    I hope this helps
    Not an image or image does not exist!
    Not an image or image does not exist!

  9. #9
    Just Another Geek
    Join Date
    Jul 2002
    Location
    Rotterdam, Netherlands
    Posts
    3,403
    Originally posted here by sweet_angel
    My old comp have on-board video card (S3 SAVAGE4) but I didn't get good X configuration even I've got S3 SAVAGE4 on the list of FreeBSD and what I did is I used "VESA" as video card. And this trick works for me somehow.

    Logged in as root :
    #xf86config

    And then when you have to choose video card ..pick "VESA" and choose your modes (800x600,1024x768,etc) save configuration and typed "startx"

    I hope this helps
    This should work fine for X3. Fbsd 4.7 installs X4 by default. xf86config still works but will create a X3 config instead of an X4 config. X4 should be able to use an X3 config. But it's better to run XFree86 -configure instead.

  10. #10
    Senior Member
    Join Date
    Mar 2003
    Posts
    245
    XFree86 kicks a lot of noob's butt because they don't know these crucial things:

    - Vertical and Horizontal refresh rate their monitor is capable of,
    e.g. 30-70 Hz Horizontal, 50-160 Hz Vertical

    - The exact video chipset of your video card

    - How much video RAM your video card has

    - What display resolutions your monitor/video card are capable of

    - What kind of mouse you have,

    e.g. If you are running Linux, and you have a scrollwheel mouse, you want to
    have an entry like this in /etc/X11/XF86Config for your mouse:

    Option 'Device' '/dev/psaux'
    Option 'Protocol 'imps/2'
    Option 'Emulate3Buttons' 'true'
    Option 'ZAxisMapping' '4 5'

    (Replace single quotes with double quotes, keyboard mapping of double quote character
    seems to be goofed when I am on this site)

    Don't know if that helps anybody, but this has to be one of the most frequently asked
    questions about XFree86/UNIX on the internet.
    Get OpenSolaris http://www.opensolaris.org/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides