file sharing whith samba
Results 1 to 7 of 7

Thread: file sharing whith samba

  1. #1
    Junior Member
    Join Date
    Sep 2002
    Posts
    13

    Question file sharing whith samba

    hi all

    I ve got two computers on a local network
    One has Windoze Me the othe has linux Mandrake 9.0

    When accessing shared files from the windoze box i get a prompt for a password
    And when i acces from the linux box i can acces all file but not open them or download them
    thx for any help!

  2. #2
    Member
    Join Date
    Jan 2003
    Posts
    36
    Concerning the password you might have to deal with the smbpasswd command (man smbpasswd) and generate a password file in your samba directory ( /etc/samba on a SuSE box).

    Concerning the access to the files it could be helpful if you would post your (anonymised) smb.conf file.

    Are you using SWAT to configure Samba? It's very helpful I think.

  3. #3
    Member
    Join Date
    Mar 2003
    Posts
    99
    Do you have permission to accss those files from the user you are logged in as?

    smbpasswd is the correct solution for the password problem....
    smbpasswd -a <username>

    It will prompt you for a password for that user then.

  4. #4
    Master-Jedi-Pimps0r & Moderator thehorse13's Avatar
    Join Date
    Dec 2002
    Location
    Washington D.C. area
    Posts
    2,883
    Yes, you certainly have a permission problem and as pointed about above, SWAT is the best way to go about resolving it. You run it locally through your web browser. On RH it runs on port 900 I believe and I can't see why it would be different on the mandrake distro.

    There is an entire section within SWAT that allows you to setup permissions for your shares. It took me about 2 days to get all the kinks worked out using SWAT but once I did, it has been stable ever since.

    Anyway, hope this helps out.
    Our scars have the power to remind us that our past was real. -- Hannibal Lecter.
    Talent is God given. Be humble. Fame is man-given. Be grateful. Conceit is self-given. Be careful. -- John Wooden

  5. #5
    Senior Member
    Join Date
    Apr 2002
    Posts
    634
    Configuring manually smb.conf is really bothering, but it is possible. I personally didn't install SWAT after my last Linux re-installation and I configured everything directly. The weirdest thing is that my access throught my file-sharing little network is faster with Samba than with Windows!

    It reminds me you should also check your Windows permissions and not only Linux permissions. I know it can seems stupid but it is easy to forget to configure your Windows boxes after a hard day spent to configure Linux ones.

    KC
    Life is boring. Play NetHack... --more--

  6. #6
    Member
    Join Date
    Mar 2003
    Posts
    99
    Keep in mind when using SWAT. All those nice little comment fields that are in your smb.conf file will go away once you update and save the configuration using SWAT. You'll then have to do some searching or get a book to figure out what some of the fields mean and how to use them....FYI....

  7. #7
    Senior Member
    Join Date
    Jul 2001
    Posts
    281
    This is not to knock on SWAT, but I think if it's your first time you should configure the shares yourself. SWAT may be nice but you don't learn a damn thing. Such as the veto files issue I had when I installed the Office XP Pro CD on my server. Therefore I am going to show you a sample of my samba.conf. I removed all the comments from my server because I do not believe in them, in my httpd.conf however I do have comments to remember WTF I did. Notice on the veto files I took out the riched.dll because whatever is in the veto files, is hidden even though it is really there. It's a protection against some viruses.

    Also make sure that you have permission to read and write to the files on the linux server. If samba was not configured properly in the beginning you may have odd permissions.

    [global]
    unix extensions = yes
    client code page = 850
    character set = ISO8859-15
    socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
    workgroup = Bigknight
    os level = 2
    null passwords = yes
    printcap name = CUPS
    encrypt passwords = yes
    time server = yes
    veto files = /*.eml/*.nws/*.{*}/
    wins support = no

    [homes]
    comment = Home Directories
    valid users = %S
    browseable = no
    writeable = yes
    create mask = 0640
    directory mask = 0750

    [samba]
    writeable = yes
    path = /data1
    create mask = 0640
    comment = Samba
    directory mask = 0750
    guests = yes
    public = yes

    [data]
    path = /data1/data
    writeable = yes
    browseable = yes
    guests = no
    public = yes

    [zipfiles]
    browseable = yes
    valid users = louie
    writeable = yes
    guests = no
    public = yes
    path = /data1/zipfiles

    [mp3]
    path = /data1/mp3
    writeable = yes
    browseable = yes
    guests = no
    public = yes

    [pics]
    browseable = yes
    valid users = louie
    writeable = yes
    guests = no
    public = yes
    path = /data1/movies
    You\'re either a 0 or a 1, alive or dead

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides