Compiling C++ progs in RH 8
Results 1 to 2 of 2

Thread: Compiling C++ progs in RH 8

  1. #1
    Join Date
    Jan 2002

    Compiling C++ progs in RH 8

    hi Guys
    I had recently installed RH 8 on my system. Now I want to compile some C++ progs on it using g++ but the problem I am having is that it can't seem to find the "include" files. I tried to give "/usr/include" and also a directory named "/usr/include/C++/version3.2" or something like this but still it doesn;t work. Someone told me look for a "g++-vx" (x=2or3) directory but its not there.
    Please help wht shud I do.

  2. #2
    Senior Member
    Join Date
    Jan 2003
    Hey Hey

    This might help.. but then again it might now.. When I installed RH 7.1 i didn't have c++ support.. and I couldn't figure it out.. I installed on a few machines and it was always the same result.. no c++.... after saying wtf for a while... i actually went onto the cd.. found the rpm w/ the headers and extracted it... that fixed all my problems.. for some reason i just wasn't getting the header file rpm..
    check the CD.. or else find it on the net.. something along the lines of
    gcc-c++-2.95*.rpm.... the 2.95 could be newer. i haven't installed an new version of *nix in a while.. or any newer files... after you rpm -Uvh that file.. the directory you should find the header files in will be /usr/include/g++-3/ (number may vary depending on version) but that would be my first suggest.. especially if you have the cd laying around. throw it in.. find that rpm on the CD... and rpm -Uvh it..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts