Slackware internet connection problem
Results 1 to 3 of 3

Thread: Slackware internet connection problem

  1. #1
    It's a gas!
    Join Date
    Jul 2002

    Slackware internet connection problem

    Im using the PPP dialup utility in Gnome.
    When i click connect the modem is initialized, dials up then gives me a message saying connection established!
    However, after a few seconds i get disconnected and a message pops up saying 'pppd daemon died unexpectedly'.

    I have lowered the speed setting of the modem and have uncommented noauth in /etc/ppp/options.

    Here is the log from /var/log/messages

    ppp generic driver version 2.4.1 
    pppd 2.4.1 started by root, uid 0 
    using interface ppp0 
    connect: ppp0 <--> /dev/tty1 
    connection terminated 
    Ive also tried connecting as root but same problem!

    Any ideas?


  2. #2
    Senior Member
    Join Date
    Mar 2003
    Depending on how long it takes for your daemon to die, a script run in cron say every 2 - 3 minutes to check for the daemon and restart it if down may help. You'll get a relatively good idea of any trends in the daemon dying that may help you find the issue. This is NOT a fix, and you should probably bring it up in a slackware mailing list. I personally have never used ppp so I don't have any expertise on pppd and it's related config files etc.


    # The list for daemons to search for
    foreach DAEMON (pppd) #this can be any daemon, or list of daemons separated by spaces.

    ps -e | fgrep "$DAEMON:t" | cut -c1-8 > /dev/null

    if ( $status > 0 ) then

    echo "Restarting $DAEMON"

    /etc/rc.d/rc.pppd restart

    Get OpenSolaris

  3. #3
    Join Date
    Mar 2003
    i had a problem similar to this once before, you might want to check with your ISP. Sometimes a problem on there end can also disconnect you, im not sure if youv tried that as an option or not but call them up and see what going on there, if you still have problems....then i have no idea lol sorry, butp calling my ISP usually fixed this problem on my end.

    i just did a lil searching and foun a big list of how tos that may help you also, im sorry i cant help more but hopefully you find the problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts