Review: Red Hat Linux 9
Results 1 to 4 of 4

Thread: Review: Red Hat Linux 9

  1. #1
    Senior Member problemchild's Avatar
    Join Date
    Jul 2002
    Posts
    551

    Review: Red Hat Linux 9

    Product Review: Red Hat Linux 9

    Well gang, I decided to bite the bullet and take the new Red Hat 9 for a spin around the block and see what the folks from North Carolina have whipped up for us this time. Red Hat 9 is supposed to be essentially a polished and tuned up version of Red Hat 8.0. As most people know, I'm more of a "do-it-yourselfer" so I tend to prefer distributions like Debian and Gentoo over Red Hat and Mandrake, but I do like to check things out from time to time and see what the folks in mainstream Linux are up to. I didn't really have anything better to do with my weekend anyway, so....

    Here's the nitty gritty. It's 3 CDs, which I downloaded from the Usenet group alt.binaries.cd.image.linux. There are more CDs of source code, but there's no need to waste CD blanks on source for something I'm just trying on for size.

    The graphical installer still looks pretty much like it has since the 6.x days, although since 8.0 it sports the nifty Bluecurve theme and looks quite a bit more polished than older versions.

    There were a few differences in the installation, though. For one thing, there is no longer an option to create a user after setting the root password. At first this worried me a bit, since I'm always concerned about newbies working in the root account, and I feared that such an omission would encourage that. But my fears were eased shortly when, on the first boot, I was asked to create a user account, so I guess that's OK.

    The default package selection is much betetr than in 8.0, with packages like Pan and other common applications now being included. The excellent Galeon browser is still left out of the default for some reason, so I had to choose it by hand. I don't like the OpenOffice bloatware, so I unchecked it in favor of AbiWord and Gnumeric. During package installation, I was treated to a slideshow of fortune cookie-type fortunes with amusing (albeit somewhat lame) sayings, ranging from "Red Hat: Better than duct tape" to "Help! I'm trapped in the lab and I have to type fortunes for pizza or I'll starve!" Are you kidding me? Fart!

    One omission in the installer that I found far more ominous was the lack of an option to test the display adapter and monitor configuration. The installer correctly detected my ATI Radeon 7500 and my ViewSonic A90, but there was no way to test it. At least if there was a test button there, I couldn't find it. This made me a bit nervous, as I always test the configuration when installing a new distribution for the first time. So I chose my usual resolution of 1400x1050 16-bit and hoped for the best. Unfortunately, this one didn't work out. Upon reboot, the X server was unable to start and my monitor powered down with a "frequency out of range" error message. Great.

    I was able to kill the X server and drop back to a command line with <Ctrl><Alt><Backspace> and start X with 'XFree86 -config' to generate a new XF86Config and copy it to /etc/X11/. Then startx took me into the Gnome desktop.... at a resolution of 1920x1440. WTF? 1600x1200 is a little too high for my 19" monitor, but no matter what I tried, I couldn't get 1400x1050 to work even though I use that resolution with Gentoo with no problems. I ultimately had to settle on 1600x1200. Although I was able to deal with the display problems, how many newbies would know how to do that? The omission of a "test configuration" button is an unpardonable sin on Red Hat's part. This is their idea of polish?

    Once I got everything installed and running, I found myself in the familiar default Bluecurve interface. Same icons, same desktop, same background, same everything. To tell you the truth, I can't tell the difference between Red Hat 8 and 9 from looking at the desktop. Red hat has added an 'Open Recent' folder to the menu, a la Windows, and some menu items have been rearranged. I have to question the wisdom of placing Gnome Toaster in 'System Tools > More System Tools > CD Writer' It seems to me that it would more properly belong in the 'Sound and Video' group or some other place that's not hidden away 3 levels deep. The icons look like they were drawn with Crayon, but they are still much nicer than the default Gnome icons.

    One thing that has absolutely blown me away in both Red Hat 8 and 9 is the fonts. I don't know what Red Hat has done to achieve this, but they are absolutely superb. They look as good as any I've seen. I will be undertaking an extensive study of Red Hat's font configuration to see if I can get this effect under my Gentoo installation.....

    Red Hat still doesn't ship with MP3 support, but that is in no way Red Hat's fault and I think the fact that so many people are bent out of shape over it exposes a fundamental hypocrisy in the free software community. A lot of criticism has been directed toward the free software community, especially by the music and movie industries, claiming that we are just a bunch of pirates out for what we can get for free. Then the community rallies and says that free software is about philosophy and a better way to develop software, yada yada yada... but let a piece of proprietary software get pulled because the owner is asserting patent rights, and everybody gets up in arms toward Red Hat.

    There is also no video player such as Xine or MPlayer included, which I think is a mistake. Everybody understands why they can't ship libdvdcss and certain codecs, but why can't they include the basic player and leave the user to add that support like they do with XMMS?

    Another place where Red Hat 9 falls down for me is the kernel. I need NTFS file system support and I need a patch for Netraverse Win4Lin, so I tried to compile a stock 2.4.20 kernel with the Win4Lin patch. No matter how I compiled it, Red Hat simply would not behave on anything except the Red Hat kernel. It was unable to start several USB devices, despite the fact that I had every USB option enabled in the kernel. And no matter what I did, it would not allow me to access my 2 CD-ROM drives. The kernel was detecting and identifying the IDE devices, but they weren't present in /dev/ unless I booted the Red Hat kernel. I even loaded the Red Hat configuration file into my new kernel to be sure I had everything Red Hat required, but it simply wouldn't behave. And let's make no mistake about it... I'm far from knowing everything, but I'm no newbie when it comes to compiling kernels. I've been doing it since 1.x and I've done it for just about every distribution there is, and this beast just will not take my new kernel.

    I also couldn't get up2date to work for me. I have been using it on 8.0 without problems, but my account now refuses to work on 9. It just gives me a cryptic error message:

    This server does not have a valid entitlement for Red Hat Network.
    Please visit https://rhn.redhat.com/network/systems/entitlements.pxt
    or login at https://rhn.redhat.com, and from the "Systems" tab,
    select "System Entitlements" to enable RHN service for this server.
    Explanation:
    An error has occurred while processing your request. If this problem
    persists please submit a bug report to rhn-help@redhat.com.
    If you choose to submit the bug report, please be sure to include
    details of what you were trying to do when this error occurred and
    details on how to reproduce this problem.
    I followed the link, and it seems Red Hat is under the impression that I now have 3 systems on RHN and that I need to purchase support for 2 of them. Including my current installation. So as near as I can figure, it seems that if you register for your 1 free system and then reinstall, they count it as a new system and want you to pay for support.

    So.... the long and the short:

    Pros: Bluecurve is the slickest, most polished GUI available for Linux today, IMO. It's an absolute pleasure to work in.

    Cons: Lack of attention to detail. Too much stuff doesn't work, no compelling reason to upgrade.

    Summary: I see absolutely nothing in Red Hat 9 to justify a new release, and certainly nothing to justify a major version update. Bluecurve is extremely polished and pleasent to work in, and the fonts are great, and I think it's by far the best GUI available for Linux today. Unfortunately, for a release that was supposed to be essentially a polish update, it is sorely lacking in attention to detail.

    The bottom line: If you are running Red Hat 7.x or earlier or another distribution, it's worth your time to check it out. If you are running Red Hat 8.0, skip it because there's nothing new. As for me, I'm going back to Gentoo.
    Do what you want with the girl, but leave me alone!

  2. #2
    Senior Member cheesegoduk's Avatar
    Join Date
    May 2002
    Posts
    224
    Yer, I agree that the lack of a test button is a VERY big misktake on redhats half, new users would not know what to do if the config failed and they had to reconfigure it by hand and would probally give up.

    As for ntfs support on redhat 9 look here
    http://linux-ntfs.sourceforge.net/info/redhat.html

    This site has the ntfs drivers as a rpm and have recently been rebuilt for redhat 9, I installed them and within seconds I was listening to my music from my ntfs drive.

    Also a good place for getting prebuilt rpms of programs for redhat 9 is
    http://shrike.freshrpms.net/
    This site has the required rpms on to get dvds up and running

    Yer, its a shame that there is no included media player, There should be one, again so that the new users wouldn't give up so easy.

    Hopefully future redhat release will fix small bugs like the test button and the lack of a media player.

    Also if your upgrading your release of redhat and then find that you can no longer use up2date. You will need to go to there website and click the redhat network link and log in and delete your older systems and then reregister the system. This is due to redhat now charging for more than one system at a time on the same email account. Whist many do not agree with this, You have to understand that being opensource it is harder for them to make money(look at mandrake). Although I think the $60 yearly price is a bit to much.

  3. #3
    hey problemchild nice post but i do have an answer to your problem with the up2date yes i know you have to pay if you want support and all the stuff but you can also disable the status of the first two servers and activate the new one so you can get the up2date
    Is like they give you one free sampler but you can always have the option to take different as long as you finished with the other one.
    Just a my 2 cents
    \"Knowledge is Power\"

  4. #4
    Senior Member
    Join Date
    Oct 2001
    Posts
    186
    Just as a note even though its not redhat, when I installed debian, I dont believe there was a test button which kinda made me nervous, but all worked out well. Maybe ill give the new redhat a look. Good post. Thanks.
    Ben Franklin said it best. \"They that can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety.\"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •