disabling autoplay in win 2k
Results 1 to 4 of 4

Thread: disabling autoplay in win 2k

  1. #1
    Join Date
    Jun 2002

    Post disabling autoplay in win 2k

    I seem to be unable to disable autoplay in Windows 200 and the help files are not very helpful. Anyone...?


    EDIT: typo supposed to be Windows 2000 (obviously)
    ERROR: No Keyboard Detected
    Press F1 to continue....

  2. #2
    Senior Member
    Join Date
    Feb 2003
    Memphis, TN
    you should be able to go into my computer then right click on the cd-rom drive and select properties. There should be a tab at the top that says autoplay. Inside that tab I believe that it will give you some options as to whether or not open the files.

  3. #3
    Join Date
    Jun 2002
    There is no tab titled Autoplay in any properties window for the CD drives that I can find.
    ERROR: No Keyboard Detected
    Press F1 to continue....

  4. #4
    AO übergeek phishphreek's Avatar
    Join Date
    Jan 2002
    Are you looking for autoplay or autorun?
    By default, if you have a CD drive and sound card installed and configured in Windows 2000, simply placing an audio CD in the player will cause it to automatically start playing. However, you can disable this feature using the following:

    1. Double-click My Computer.
    2. On the Tools menu, click Folder Options, and then click the File Types tab.
    3. In file types, click AudioCD, and then click Advanced.
    4. In Actions, click Play, and then click Set Default.

    Please Note:
    (i) You can temporarily disable AutoPlay by pressing SHIFT while inserting an audio CD.
    (ii) Repeating steps 1 to 4 will enable AutoPlay.
    (iii) When "Play" is displayed in Bold font, AutoPlay is enabled. When Play is not in Bold font, AutoPlay is disabled.
    (iv) If you have third-party software installed, such as RealPlayer, your options may be different than the steps above.
    These entries also work in Windows 2000, but an additional entry may also be used. If Autoplay is on for a CD-ROM changer, it will cycle all slots as you change media.

    A Value Name of NoDriveTypeAutoRun, a REG_DWORD data type, can be configured to disable Autoplay on all drives of the specified types. NoDriveTypeAutoRun can be located at:




    The data value to set is determinined by adding the following:

    Value Meaning
    0x1 Disables Autoplay on drives of unknown type.
    0x4 Disables Autoplay on removable drives.
    0x8 Disables Autoplay on fixed drives.
    0x10 Disables Autoplay on network drives.
    0x20 Disables Autoplay on CD-ROM drives.
    0x40 Disables Autoplay on RAM disks.
    0x80 Disables Autoplay on drives of unknown type.
    0xFF Disables Autoplay on all types of drives.
    A data value of 0x95 is the default, which disables Autoplay on unknown drives, floppy drives, and network drives.
    If Autorun is 0, Autoplay is disabled on all drives. If Autorun is 1, you can hold down the shift key as you change media to prevent Media Change Notification (MCN). Appropriate settings in NoDriveAutoRun also disable Autoplay.

    When Autoplay is enabled it begins as soon as you insert media, so setup programs and music start immediately.

    NOTE: If NoDriveAutoRun or NoDriveTypeAutoRun are set in the HKEY_LOCAL_MACHINE hive, then these setting in HKEY_USERS and HKEY_CURRENT_USER are ignored.

    NOTE: If you set the NoDriveTypeAutoRun value via the Disable Autoplay Group Policy, you can add the CD-ROM drive type or disable Autoplay on all drive types. Any other settings must be done via the registry.
    If I may suggest something to you... a lot of this tweaking can be managed much better by using a utility called XTeq . I use it on 2k and XP. I think it is much better than tweaking everything by hand because you can undo anything that you change. You don't have to remember all the registry keys you changed and such...

    m$ also has one called tweakUI. That does similar stuff... but not as much. It is part of the m$ "power toys".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts