Results 1 to 4 of 4

Thread: gentoo

  1. #1
    Senior Member
    Join Date
    Dec 2001


    Well I downloaded gentoo and started to install last night. Everything seemed fine but I kindof got hung up on 2 parts. Fstab and Grub. I thought I had it right but when I restarted it just came up and said grub and would not do anything.

    Ok. First I will give you my partition information

    Device Boot Start End Blocks Id System
    /dev/hda1 * 1 14 105808+ 83 Linux
    /dev/hda2 15 81 506520 82 Linux swap
    /dev/hda3 82 3876 28690200 83 Linux


    next is filesystem info

    /dev/hda1 (boot) = ext3
    /dev/hda2 (swap) = swap
    /dev/hda3 (root) = ReiserFS

    | FSTAB |

    # /etc/fstab: static file system information.
    # noatime turns off atimes for increased performance (atimes normally aren't
    # needed; notail increases performance of ReiserFS (at the expense of storage
    # efficiency). It is safe to drop the noatime options if you want and to
    # switch between notail and tail freely.

    # <fs> <mount point> <type> <opts> <dump/pass>

    # NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.

    /dev/hda1 /boot ext2 noauto,noatime 1 2
    /dev/hda3 / ??? noatime 0 1
    /dev/hda2 none swap sw 0 0
    /dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,ro 0 0
    proc /proc proc defaults 0 0

    Ok, I believe everything i have here is right but I am not sure of the correct setting to put where the ??? are.. The file system is ReiserFS, just not sure what i have to put in there

    | grub |

    Ok, I am pretty shure I messed this up.

    grub> root (hd0,0)
    grub> setup (hd0)


    default 0
    timeout 30

    title=Gentoo Linux
    root (hd0,0)
    kernel (hd0,0)/boot/bzImage root=/dev/hda3


    Ok based on the file system and fdisk info that I provided can anyone see what i did wrong here. Just to recap, I go to boot the computer and it just says grub and will not do anything. Also please dont forget to answer what i should replace ??? with in fstab.

    Thansk in advance.
    Violence breeds violence
    we need a world court
    not a republican with his hands covered in oil and military hardware lecturing us on world security!

  2. #2
    Senior Member
    Join Date
    Jul 2001
    Im not currently using reiserfs, but according to everything I have seen in a brief search, you should replace




    I have seen 3 different fstab samples in a quick google search.

    as for your grub setup, it looks ok to me...

    grub> root (hd0,0) <----------- This should point to your /boot partition, which it does, according to all the other infor you gave.
    grub> setup (hd0) <------------ This should install grub to the MBR of hd0, which again, looks fine.

    as for the grub.conf(where I think you may have your problem, here is whatthe info on my linux partition is.

    root (hd0,0)
    kernel /vmlinuz-2.4.18-xx ro root=LABEL=/ hdc=ide-scsi
    initrd /initrd-2.4.18-xx.img

    On yours, you should replace my root=LABEL=/ with root=/dev/hda3, I think.... unless you ran e2label and labelled the partion /dev/hda3 as /, in which case you should proibalby also change your fstab to read

    LABEL=/ / reiserfs etc... etc...

    I notice w differences with yours, first, you have (hd0,0) in front of the path in your kernel statement, Im guessing that you need to remove that. You have already told it where to look for /boot/everythingelse when you told it root (hd0,0).
    That may help you out, also, you dont seem to specify an initial ramdisk with initrd

  3. #3
    Senior Member
    Join Date
    Aug 2002

    Re: gentoo

    Originally posted here by Euclid

    /dev/hda1 /boot ext2 noauto,noatime 1 2
    /dev/hda3 / ??? noatime 0 1
    /dev/hda2 none swap sw 0 0
    /dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,ro 0 0
    proc /proc proc defaults 0 0

    Is that gentoo rc4 ?. Did you make your partition like this:
    # mke2fs -j /dev/hda1
    # mkswap /dev/hda2
    # mkreiserfs /dev/hda3
    If so.. I think you should have configuration like this:
    /dev/hda1                    /boot                 ext2	 noauto,noatime	           1 2
    /dev/hda3                       /                     ext3	 noatime                              0 1
    /dev/hda2                    none                swap	 sw                                      0 0
    /dev/cdroms/cdrom0   /mnt/cdrom      iso9660	 noauto,ro                           0 0
    proc                              /proc                   proc	 defaults                              0 0
    And I think your grub configuration is ok

    Not an image or image does not exist!
    Not an image or image does not exist!

  4. #4
    Senior Member
    Join Date
    Jul 2001

    A couple of corrections...

    Unless gentoo is very much different from other distros......

    if he created the /boot filesystem with

    mke2fs -j /dev/hda1

    then that should be set to ext3 in fstab(although ext2 would work as well). the -j option is journalling, which is the major difference between ext2 and ext3. If it is set to ext2, it will work, just with journalling turned off, not a big deal, but the next one is a bit of a big deal.

    As for /dev/hda3, if he formated that with reiserfs, it should definitely not be set to ext3. Yes reiserfs is a journalling filesystem as ext3 is a journalling filesystem, but they are not the same, and setting his reiserfs filesystem to ext3 in fstab won't work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts