Results 1 to 4 of 4

Thread: Knoppix GSM dial in.

  1. #1

    Knoppix GSM dial in.

    The setup is as follows:

    Laptop Voyager 3000
    CPU: PII 266 mHz
    MEM: 32 MB
    HD: 2 Gig

    Currently the installed OS is Windos 98SE.
    I use it in conjunction with an Siemens M35i cellular phone.
    I got the data cable including the modem drivers and the software for Windows.

    I have booted the laptop a few times using a knoppix bootable cd.
    What I would like to do is to use this machine as an security auditing tool and I find knoppix would be quit suitable to accomplish this task.
    However, I am sorta MS spoiled and therefore a *nixnoob.
    I have some experience and I am not afraid of that command line.
    I used mandrake, redhat and a bit of slack before.

    For some reason I cannot connect to the net using my Siemens mobile phone.
    The phone is connected through the first serial port.
    The KPPP utility did not find the modem in /dev/modem so I tried /dev/ttyS0. It reckonized something cuz it told me the modem was ready.
    However the test showed me the following:
    ATI1 032 ERROR
    I opened up the terminal and tried:
    The phone started dialing and I got a quick response telling me:
    Next I tried the ISP number and got connected.
    Whenever I tried to type a command (like ath) however I got hung up as soon as I started typing.
    When I tried:
    echo atdt+6ISPNUMBER > /dev/ttyS0
    I got nothing.

    I configured KPPP for the account I want to use and press connect.
    No connection is established.
    The 'Busy connecting' screen shows me 'modem is being initialised' and the log window shows me 'expecting ok'. There is no dial made.

    The device is configured as follows:
    Modem-device /dev/ttyS0
    Flow-controle Hardware[CRTSCTS] (I tried software XON/XOFF)
    Line end CR (I tried others)
    Speed 19200 (same as in windos, tried other speeds)

    Now my question:
    Am I missing something ?
    How can I get my device to work under linux ?

    I would not mind installing knoppix on the hard drive if that would be neccesary.

    Any help would be appreciated !


    I cross-posted this question on linuxquestions.org

  2. #2
    Senior Member
    Join Date
    Aug 2002

    Try using external modem. I meant don't use internal modem from your laptop and then try reconfigure your device (dev/modem,dev/ttyS0,etc)

    Not an image or image does not exist!
    Not an image or image does not exist!

  3. #3
    Thanks for your reply sweet_angel.

    The device allready is external (gsm with a data cable on serial port one).
    It accepts modem terminal command if i config it on /dev/ttyS0 (not on /dev/modem).
    It is just the KPPP prog that keeps waiting for 'OK' whenever I try to connect to the ISP.

    I used the terminal command in KPPP and it accepts atdt+6ispnumber. However from a normal (bash) terminal I get nothing. (echo atdt+6ispnumber > /dev/ttyS0)

    I would really like to use knoppix in conjuction with this cellular !

  4. #4
    Sorry for bumping this thread up but I never got to solve my problem.
    Read quit some stuff I found at google but still no luck.

    When I use the terminal from KPPP configuration and try atdt +ispnumber it dials okay and makes a data connection.
    When I use the Querry modem i get the following
    ATI [nothing]
    ATI 1 [nothing]
    ATI 3 AT13 ERROR
    ATI 4 AT14 ERROR
    ATI 5 AT15 ERROR
    ATI 6 AT16 ERROR
    ATI 7 AT17 ERROR

    I have no clue on how to get this mobile phone modem to work but perhaps some *nix guru can shed some light on this, point me in the right direction.

    I have attached the inf-file for the modem in Windows.

    Help would really be appreciated.


    I forgot to add. I have installed slackware 8.1 in the mean time on this laptop so all files can be edited.
    I just don't know where to look as a *nix noob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts