Nessus Prob
Results 1 to 7 of 7

Thread: Nessus Prob

  1. #1
    Senior Member
    Join Date
    Aug 2002
    Posts
    508

    Nessus Prob

    Hi guys/girls,

    I am trying to set up nessus but something went wrong.

    # /usr/local/sbin/nessus-mkcert
    -------------------------------------------------------------------------------
    Creation of the Nessus SSL Certificate
    -------------------------------------------------------------------------------
    -------------------------------------------------------------------------------
    Creation of the Nessus SSL Certificate
    -------------------------------------------------------------------------------
    Creation of the Nessus SSL Certificate
    -------------------------------------------------------------------------------

    This script will now ask you the relevant information to create the SSL
    certificate of Nessus. Note that this information will *NOT* be sent to
    anybody (everything stays local), but anyone with the ability to connect to your
    Nessus daemon will be able to retrieve this information.


    CA certificate life time in days [1460]: 1460
    Server certificate life time in days [365]: 365
    Your country (two letter code) [FR]: AU
    Your state or province name [none]: none
    Your location (e.g. town) [Paris]: Brisbane
    Your organization [Nessus Users United]: Nessus Users United

    And then I type "enter" and I've got this error"





    -------------------------------------------------------------------------------
    Creation of the Nessus SSL Certificate
    -------------------------------------------------------------------------------
    -------------------------------------------------------------------------------
    Creation of the Nessus SSL Certificate
    -------------------------------------------------------------------------------

    An error occured while generating the certificates and/or keys !

    Do you want to save openssl output in a file for further analysis ? (y/n) [y] Where should I save this file ? [/root/openssl-output]

    Press [ENTER] to exit

    #


    Why error? what went wrong?


    Thanks in advance for your help



    Annya
    Not an image or image does not exist!
    Not an image or image does not exist!

  2. #2
    Member
    Join Date
    Dec 2001
    Posts
    87
    Did you have a look at the openssl output? Is your openssl version up to date?

  3. #3
    Senior Member
    Join Date
    Aug 2002
    Posts
    651
    Heya Angel. Maybe you are having a problem similar to that of thehorse13 here . I am not sure what versions of Linux and Nessus you are using, but it sounds like you may be having the same sort of trouble. This was also addressed on the Nessus list. It may be a good thing for you to subscribe to it in the future - although, I must admit, it is very high in traffic!


    Hope that helps.


    t2k2
    Opinions are like holes - everybody\'s got\'em.

    Smile

  4. #4
    Master-Jedi-Pimps0r & Moderator thehorse13's Avatar
    Join Date
    Dec 2002
    Location
    Washington D.C. area
    Posts
    2,883
    I can tell you that the 2.0.3 build of nessus had OpenSSL issues with RedHat 9. I posted a work-around as seen above but I still had some wierdness none the less.

    The version of nessus and the version of Linux will be most helpful. I can tell you that my issue was addressed in the latest version of nessus (2.0.4).

    Hope this helps!
    Our scars have the power to remind us that our past was real. -- Hannibal Lecter.
    Talent is God given. Be humble. Fame is man-given. Be grateful. Conceit is self-given. Be careful. -- John Wooden

  5. #5
    Senior Member
    Join Date
    Aug 2002
    Posts
    508
    Hi,

    Thanks guys I am using same version as Thehorse13 (nessus-2.0.4) . I think I am going to try old version it might be works

    Cheers

    [edit]I installed nessus-2.0.4 on my FreeBSD 4.8 laptop and yupe ownsleftfoot...my openssl already upgraded but still have same problem [/edit]
    Not an image or image does not exist!
    Not an image or image does not exist!

  6. #6
    Senior Member
    Join Date
    May 2003
    Posts
    115
    i hate to say this, but so many program that i use were broken on rh9, i actually had to revert back to rh8 but didn't do the up2date for openssl and everything seems to be working. and i upgraded versus fresh install. my friend in germany is working on this, but haven't heard back yet.

    as you can see i have lots of time to do this at work

    w0rm3y

  7. #7
    Senior Member
    Join Date
    Aug 2002
    Posts
    508
    Hi,

    I've already solved this problem by myself , What I've done is I rebuild my kernel and turn on "device for bpf" and now I am using Nessus 2.05 and I tried Nessus 2-04 too...and I don't have problem with that , which is cool..

    Cheers
    Not an image or image does not exist!
    Not an image or image does not exist!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides