openssl problem with libcrypto.so.2
Results 1 to 2 of 2

Thread: openssl problem with libcrypto.so.2

  1. #1
    Member
    Join Date
    Jun 2002
    Posts
    44

    openssl problem with libcrypto.so.2

    I recently installed RH 9 and it comes with @instigate lib]# rpm -q openssl
    openssl-0.9.7a-5

    in the /lib folder the files installed are
    libcrypto.so.0.9.7a and libcrypto.so.4

    Im trying to install Ethereal and it requires libcrypto.so.2

    I tried to use a symbolic link for libcrypto.so.2 to libcrypto.so.0.9.7a then to libcrypto.so.4. Both with no luck. Each time I tried to install Ethereal with one of the symbolic links it would complain about the libcrypto.so.2 file missing.

    Ive attempted many times to try and use up2date to get an update from the RHN but since ive only got a demo version I cant ever get logged onto it for an update.

    Any suggestions?

    Im fairly new with linux, so excuse me if this question might sound stupid. But couldnt I just get this file from someone that already has it on their computer and just move it into the /lib folder?
    Os1LaYr5

  2. #2
    Senior Member
    Join Date
    Feb 2003
    Posts
    109
    It sounds like your OpenSSL install is broken. You can go to the OpenSSL website and get a source tar, and also try getting a newer source of Ethereal. If you still have trouble, try another distro like Mandrake, or go out and buy the full version of Red Hat.
    $person!=$kiddie or die(\"Alas, die you hotmail hacker!!\");
    SecureVision

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •