Drive Letters changed after 2000 Server Install (multiboot)
Results 1 to 4 of 4

Thread: Drive Letters changed after 2000 Server Install (multiboot)

  1. #1
    Member
    Join Date
    Aug 2002
    Posts
    38

    Drive Letters changed after 2000 Server Install (multiboot)

    Hiiiii,

    OHHHH NOOOO, Could someone pleeeease help me, i kind of messed up one of my computers. OK here is what happen, i had a WINXP box dual booting with Linux 7.3, everything was fine. I used the second harrdrive for linux and first for xp. But i wanted to add SERVER 2000 so i used partition magic and created another partition F: drive and i installed windows server on that. But when i reboot, all that started was Windows 2000 Server it didnt give me the boot screen option. But when i go into my computer and look at all the partitions they all got messed up. It use to be

    Harddrive 1
    Windows XP on C: --NTFS
    Extra Partition D: (extra partition)--NTFS

    Now when i look its:
    "C:" Has these files on it
    System Volume Information
    ARCLDR
    arcsetup
    autoexec
    boot
    config.sys
    IO.sys
    msdos.sys
    ntdetect
    ntldr

    "D:" No Change (extra files)

    "E:" Has all my files for my Windows XP install

    "F:" Windows 2000 Server, Is my created partition for Server with Documents Setings Inetpub,Program files,system volume infornation,winnt,pagefile.sys

    Im not sure how to get this all back to normal. The First hardrive (Disk 0 - is basic)

    Here is what my Boot.ini files look like on "C:" and "E:"
    C: boot.ini
    [boot loader]
    timeout=30
    default=multi disk rdisk partition(3)\WINNT
    [operating systems]
    multi disk rdisk partition(3)\WINNT="Microsoft Windows 2000 Server" /fastdetect

    E:boot.ini
    [boot loader]
    timeout=30
    default=multi disk rdisk partition(1)\WINDOWS
    [operating systems]
    multi disk rdisk partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
    C:\linux.bin="Linux 7.3"

    What would be the best way to fix this or least try to get it Windows XP working again!!! Help!
    Thank You

    Tasha

  2. #2
    The Iceman Cometh
    Join Date
    Aug 2001
    Posts
    1,209
    Try changing the boot.ini on the C: drive to the following (make sure you back it up first....)

    Code:
    [boot loader] 
    timeout=30 
    default=multi disk rdisk partition(1)\WINDOWS 
    [operating systems] 
    multi disk rdisk partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect 
    multi disk rdisk partition(3)\WINNT="Microsoft Windows 2000 Server" /fastdetect 
    C:\linux.bin="Linux 7.3"  <Not really sure about this one...>
    That should (at least) get you the option to choose between 2000 and XP...

    AJ

  3. #3
    Banned
    Join Date
    Apr 2003
    Posts
    3,839
    couldn't he just go to Run-> MsConfig-> Boot.ini..and select the OS he want to boot with ???

  4. #4
    Senior Member
    Join Date
    Jan 2003
    Posts
    3,914
    When you installed 2k It would have taken over the MBR (Master Boot Record). MS Products really like to do that.... This is why on dualboot installs you should always install the MS products first and then the Non-MS (*nix or other) products after. I'd suggest you fdisk /mbr and install a bootloader of some sort. Reconfigure Lilo or use Grub or whatever you already had or find a third party one and install it. You can get boot disks for all your operating systems @ http://www.bootdisk.com if you don't already have them. You can just boot your Linux install and your XP install of the boot disks if you so desire, or you can set-up the bootloader over again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •