Sound Problem (by Klesk)
Results 1 to 9 of 9

Thread: Sound Problem (by Klesk)

  1. #1
    Junior Member
    Join Date
    Mar 2003
    Posts
    13

    sound problem

    I've just installed Slackware8.1 with sound card modules(yamaha opl3sa2/sa3) and i don't know how to make my soundcard work.I've tried alsa but when i tried modprobe it says that the modules aren't loaded.Please help?

  2. #2
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003
    Posts
    992
    You can try lsmod to see if he even loads modules and which he loaded. If it ain't in that list probably the kernel hasn't loaded it or the wrong one.
    Anyway try to figure out what driver or module your manufacturer says the best is.
    Then go into the kernel and see what module or driver is loaded, probably it's just the wrong one. you can find the kernel most of the time here : cd /usr/src/linux , then make menuconfig .

    If you think you found the right driver check it in the kernel, remake your kernel and reboot.
    Lots of those problems are just the wrong module loaded in the kernel.

    Hope this helps,
    Come and check out our wargame-site @ http://www.rootcontest.org
    We chat @ irc.smdc-network.org #lobby

  3. #3
    Junior Member
    Join Date
    Mar 2003
    Posts
    13
    the kernel has the modules but i've read that i have to add some lines in /etc/modules but i don't know what lines are corectfor my sound card

  4. #4
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003
    Posts
    992
    well, my guess is even if you have the right module in the kernel, you'll have to add it to modules.autoload ( dunno for slack but for gentoo it is).
    If this is the same just add the module without the .o extension ( I'm on one limb here)

    If you know what driver it is you could take a look in /lib/modules/*/kernel/drivers , well this is my dir for drivers and modules, dunno either for slack (* = for.ex. 2.4.20-...)

    Hope this helps a bit
    Come and check out our wargame-site @ http://www.rootcontest.org
    We chat @ irc.smdc-network.org #lobby

  5. #5
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003
    Posts
    992

    Sound Problem (by Klesk)

    Since IhateJupmedia decided to **** up the other thread , I'm reopening this one to help the guy out. The Quotes are the replies from the other thread.

    You can see his orignal question and the replys here


    I've just installed Slackware8.1 with sound card modules(yamaha opl3sa2/sa3) and i don't know how to make my soundcard work.I've tried alsa but when i tried modprobe it says that the modules aren't loaded.Please help?
    You can try lsmod to see if he even loads modules and which he loaded. If it ain't in that list probably the kernel hasn't loaded it or the wrong one.
    the kernel has the modules but i've read that i have to add some lines in /etc/modules but i don't know what lines are corectfor my sound card
    well, my guess is even if you have the right module in the kernel, you'll have to add it to modules.autoload ( dunno for slack but for gentoo it is).
    Come and check out our wargame-site @ http://www.rootcontest.org
    We chat @ irc.smdc-network.org #lobby

  6. #6
    Senior Member
    Join Date
    Aug 2002
    Posts
    508
    Hi,

    Have you edit your /etc/rc.d/rc.modules?? or maybe can you post it here.. cat /etc/rc.d/rc.modules

    What happen when you do ls -1 /dev/dsp ??
    Not an image or image does not exist!
    Not an image or image does not exist!

  7. #7
    Banned
    Join Date
    Jul 2002
    Posts
    877
    HAHAHAH IhateJupmedia, only the lamest of all kiddies would cuts and pastes things then slap it onto a screen like you do. Oh and since kiddies like downloading other peaples programs... you can have this.

    !Enjoy!

    BTW Klesk, sorry bud. Peaple here are normally alot more cooler when peaple like that stupid chump isn't around.

  8. #8
    Just a Virtualized Geek MrLinus's Avatar
    Join Date
    Sep 2001
    Location
    Redondo Beach, CA
    Posts
    7,324
    I've re-opened the thread as it didn't seem to make sense that this thread be closed because of one poor post.

    My apologies that this happened.

    // edit merged original and new thread together. The "kiddie" is actually swiftstyles I believe. Sigh.

    Goodbye, Mittens (1992-2008). My pillow will be cold without your purring beside my head
    Extra! Extra! Get your FREE copy of Insight Newsletter||MsMittens' HomePage

  9. #9
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003
    Posts
    992
    Yes it was Swift, he bragged about it on IRC, I hope he grows up soon :s
    Come and check out our wargame-site @ http://www.rootcontest.org
    We chat @ irc.smdc-network.org #lobby

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •