I've spent the last two days reading everything I could trying to get this to work.

I have a Dell Inspiron 8000 running Slackware 9.0, trying to get my Linksys WPC11 v3 wireless nic to work under linux. (It works fine under Win 2000, just to rule out any hardware problem)

I've been trying to use the wlan-ng drivers to work with the card, it seems to be recognized and the modules load fine. The wlan0 interface is becomes available, but I can't seem to really do anything with it. I am trying to figure out how to just set up the network end of it, because just about every tutorial I find uses Redhat's GUI.

Thanks for any and all help you may be able to offer. I also posted the output of some of the following commands that may help you bettter understand the problem.

ifconfig wlan0 shows:
wlan0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:9 Base address:0x100

ifconfig wlan0 displays the error
SIOCSIFFLAGS: No such device

When I try to use iwpriv for anything is outputs:
wlan0 no private ioctls.

lsmod shows the following modules loaded for the pcmcia card:
prism2_cs 62032 0
p80211 18392 0 [prism2_cs]
ds 6568 2 [prism2_cs]
yenta_socket 9632 2
pcmcia_core 38112 0 [prism2_cs ds yenta_socket]

cardctl ident shows:

Socket 1:
product info: "The Linksys Group, Inc.", "Instant Wireless Network PC Card", "ISL37300P", "RevA"
manfid: 0x0274, 0x1613
function: 6 (network)