IP Problem
Results 1 to 7 of 7

Thread: IP Problem

  1. #1
    Senior Member
    Join Date
    Aug 2002
    Posts
    113

    IP Problem

    Hello,

    I have 2 pcs at home and they are interconnected with each other. We can assume that one PC is A and the other one is B. XP is installed on both the PCs. Internet cable is connected to 'A' and due to networking between both the PCs, internet sharing is achieved. Now, the real problem is that if I specify an ip in the tcp/ip properties of 'A' then both the computers are shared but no more internet sharing. And if I do not specify the ip of 'B' in the tcp/ip properties of 'A' then internet sharing is enabled and data sharing is also enabled on both the PCs but after some days 'B' changes it's ip itself and once again I have to specify the ip in the tcp/ip properties of 'A'.

    Is there anyway that the 'B' have a permanent ip so that I do not have to share them again and again. Thanks in advance......
    Beware Clarity! A person talking to you in clear language is clearly using obsolete ideas.

  2. #2
    Senior Member cwk9's Avatar
    Join Date
    Feb 2002
    Posts
    1,211
    Using internet connection sharing in xp requires that the computer with the net connection have an ip of 192.168.0.1 and connecting comptuers need an address of 192.168.0.X starting at 192.168.0.1. Netbios should work regard less of the ip as long as both comps are on the same work group.
    Its not software piracy. Iím just making multiple off site backups.

  3. #3
    Senior Member
    Join Date
    Feb 2003
    Location
    Memphis, TN
    Posts
    3,747
    Are you Using Internet connection sharing, using a router, a proxy?

    If I remember correctly though Internet Connection Sharing requires the gateway computer (compuer connected to internet) to have an permanent IP of 192.168.0.1, and the other computers to have a and ip of 192.168.0.xxx

    If you want to give computer B a permanent Ip then go to START--->CONTROL PANEL---> NETWORK CONNECTIONS--->RIGHT CLICK ON YOUR LAN CONNECTION--->SELECT tcp/ip---THEN HIT PROPERTIES.

    Under the IP address select specify and IP address. I have a small network and keep it simple, so I use a IP address of 192.168.0.2, and a Subent Mask of 255.255.255.0

    Then ok and close it should stay that way unless you change it.
    =

  4. #4
    Senior Member
    Join Date
    Aug 2002
    Posts
    113
    Yes, the ip address of 'A' is 192.168.0.1 and whenever I specify an ip address for the 'B' then there is no more internet sharing between them. For example if I give 192.168.0.2 to 'B" then the computers are shared but this time internet sharing is disabled.

    Well cable modem is connected to the 'A' and this pc has 2 nic cards so a simple connection from the second nic to 'B'. No router or switch.
    Beware Clarity! A person talking to you in clear language is clearly using obsolete ideas.

  5. #5
    Senior Member
    Join Date
    Jan 2003
    Posts
    3,914
    I would assume you've got some kind of error somewhere in your set-up... ICS with cable is simple and requires no IP addresses to be set....

    I'd default ever setting..... (possibly delete and recreate the connections)... get computer 'A' working with the cable, plug it into computer 'B' and then on the connection on computer 'A' click on the enable ICS for the NIC connected to computer 'B' and then select the cable connection as the connection to share. Let everything run off the IP address they decide to grab. When I moved in here before we got our hub and DSL we had to do that with our cable, both computers had come off seperate networks, 1 was plugged in and working with the cable we simply connected my computer and enabled ICS and it worked fine.. IPs were all set to DHCP

  6. #6
    Senior Member
    Join Date
    May 2003
    Posts
    472
    ensure that the gateway feild in the TCP/IP properties of computer B is saet the IP of the first computer...
    guru@linux:~> who I grep -i blonde I talk; cd ~; wine; talk; touch; unzip; touch; strip; gasp; finger; mount; fsck; more; yes; gasp; umount; make clean; sleep;

  7. #7
    Senior Member
    Join Date
    Feb 2003
    Posts
    211
    U can try this configuration :
    Comp 'A' :
    Set the IP address with "192.168.0.1" for the first Nic and put "192.168.0.2" for the second Nic.
    Put subnet mask with "255.255.255.0" for noth Nics ( it ussualy show up it self automatically after u enter the IP address.
    Leave the gate way field blank , and then u put the primary and secondary DNS on both Nics ( example "202.158.X.X".
    And then hit the advance button and select the "WINS" tab menu on the top, and fill the field with the first Nic IP address ( example '192.168.0.1 ')
    and then u may restart if the system need to reboot the system, if not u can follow the next step.
    After rebooting ( if ur comp need to restart ), right klik on 'My Network Places' and select properties. Then u select the share tab menu and choose 'share internet' and u will find 2 Nic's name on the fiels ... select the first Nic name.
    Comp 'B' :
    Same with 'A' configuration, but on 'B' u have to put gateway field with the first Nic IP address ( exmp '192.168.0.1 ) and then hit advance button and fill the WINS with the first Nic IP address.

    I hope it works and i could be wrong about this mate.

    Good Luck
    When I lay me down to sleep, Pray the LORD my soul to keep.
    If I die before i wake, Pray the LORD my soul to take.

    http://www.AntiOnline.com/sig.php?imageid=389

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •