wow, linux so difficult! - Page 2
Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: wow, linux so difficult!

  1. #11
    Banned
    Join Date
    Nov 2002
    Posts
    677

    Question

    My desktop is 6 years old. I downloaded both Mandrake and Suse 8.2 evaluation. Under normal install, Mandrake installed the way I wanted but just like you the sound would not cut on. Suse 8.2 ran off CD and found every device connected.... so I wrote the modules it found for future reference.

    Other than the USB printer, that was the second biggest pisser. Motivated by a destroyed windows 2000 CD, I searched google for very helpful hints. Turned out ALSA sound drivers were installed but since I downloaded OSS/open source, it corrupted my modules.conf file. This in turn made 'sndconfig' choose an off-the-wall driver. With that speciali post, I had to manually reconstruct the modules.conf to launch the correct driver when probing. This finally worked and I am happy. Even voodoo3 Glide worked off first chance. Now I can do some productive work on this machine. USB printer stalls from time-to-time however, on the notebook with XP, the pages shoot out like I was in an industrial printing plant. The desktop is a MMX beast. Strange thing about this, the desktop is 233mmz and the notebook is p3 1ghz. I spend 85% on the desktop now. I'm happy...Linux keeps you on your toes. Fluxbox and Icewm are my desktop choises... a tad faster.

  2. #12
    Senior Member
    Join Date
    Mar 2003
    Posts
    135
    doodz...just checked the thread and saw your post. PM me if this does not explain what you need, I am not sure what part you didn't understand and what part was helpful.

    1. To see your files that are on a drive with a ntfs filesystem, you have to "mount" it. This is a command that tells linux to start looking at a filesystem. The basic format for this command is:
    mount -t filetype locationoffiles whereyouwantthem

    So, like I suggested, you should be able to see them by creating a directory somewhere (anywhere) on your linux box and then giving the mount command that includes the location of the hard drive. On my machine (a single hd dual booting xp and mandrake) my hd is listed as hda, and the windows partition is #2, and my directory that I created is at /mnt/winpartition. So I give the command mount -t ntfs /dev/hda2 /mnt/winpartition Voila, just like they were always there!

    My guess: if your second hard drive is the primary slave, it's hdb. If it's the secondary master (like my vector box) it's hdc. I don't know of a command (if there is one) that will tell you what yours is, but there's not too many combinations it could be. If there is only one partition on the drive it would be hdb1, hdc1, or whatever.

    btw, if you add a line to your fstab, it will automatically mount at boot.

    also, open up a shell and type man mount. It will give you some info. And always love google.

  3. #13
    Junior Member
    Join Date
    Mar 2003
    Posts
    3
    oh yeah, that text that d00dzattackin wrote was mine, I was accidently under his screen name. who knows how that happend...?!?! muhuhahahah j/k

  4. #14
    Senior Member
    Join Date
    Mar 2003
    Posts
    135
    aha...I thought that was what the refernece was to but wasn't for sure

  5. #15
    The Doctor Und3ertak3r's Avatar
    Join Date
    Apr 2002
    Posts
    2,744
    me thinks M$ has installed a brain sucking vortex prg in all its windaz versions.. when you work with it long enough if it hasn't sucked your intelligence right out, it will have turned your Brain to Mush.. that is my prob.. I think, ??? wait while I find another brain cell to rub together..

    In other words, I wonder if we shud ask the powers that be if a Linux Help. forum wouldn't be a Goooood Idea? cause shite guys I read as much as I can to counteract the M$ brain sucking Vortex.. or do I just need to deal with a bit of 4-20?
    I know I shud have thrown this into another thread.. but the security threads are not the place for these types of questions.. but considering.. it is currently the nearest..

    Cheers
    "Consumer technology now exceeds the average persons ability to comprehend how to use it..give up hope of them being able to understand how it works." - Me http://www.cybercrypt.co.nr

  6. #16
    Junior Member
    Join Date
    Mar 2003
    Posts
    3
    uhhhhh, uhhhhh, right-0 mr. undertaker! what ever your meant lol. Keyser, I mande a directory under mnt called windows and this is what I typed and this is what I got.

    [root@localhost gamer]# mount -t ntfs /dev/hda2 /mnt/windows
    mount: fs type ntfs not supported by kernel

    Now isnt that a bother? lol. I went to some website to get the ntfs support thingy but I installed the i386 by mistake because I have an Athlon proc and I dont know how to uninstall it. When I tried some commands it would usualy just hang like most other commands do. Just like the nvidia drivers I have, durring its installation it just freezes. Not the whole computer freezes but just the installation of the nvidia drivers. So I get the older drivers and i find out theyr not rpms anymore! So I type make or make file one of those and this error comes up:

    [root@localhost Desktop]# cd NVIDIA_kernel-1.0-4050
    [root@localhost NVIDIA_kernel-1.0-4050]# make

    You appear to be compiling the NVIDIA kernel module with
    a compiler different from the one that was used to compile
    the running kernel. This may be perfectly fine, but there
    are cases where this can lead to unexpected behaviour and
    system crashes.

    If you know what you are doing and want to override this
    check, you can do so by setting IGNORE_CC_MISMATCH.

    In any other case, set the CC environment variable to the
    name of the compiler that was used to compile the kernel.

    *** Failed cc sanity check. Bailing out! ***
    make: *** [gcc-check] Error 1

    more bother... linux is such a pain. Now I know its wrong to defend windose but windows never has this problem. neither does it have ANY of these problems I have with linux. Or maybe RED HAT SUX!!!. I remember when I had suse, now those were the good days. I was online the same day and everything worked. But it was a live-eval. lol. If anyone knows an ftp or something where I can get the suse iso's for ummm, 8.2 i think i'd be very greatful.

    So yeah, back to drivers and ntfs hard drives. If some one wants to help me do these things (access my computer and do it your self) then go ahead. I just found out how to conenct using my ETHERNET dsl modem so its all gravy. I have this service running that my friend made me install called sshd. I know its an ssh server thing but i havent touched it or made accounts or none of that basicly cuz i dont know. To tell you the truth i dont know how to open programs I install. I would usualy go to run in the taskbar menu and type the name of the program and hope it opens lol. Write back plz!

  7. #17
    Senior Member
    Join Date
    Jan 2003
    Posts
    274
    www.justlinux.com

    www.tldp.org


    Two websites no linux newbie should be without.

  8. #18
    Just a Virtualized Geek MrLinus's Avatar
    Join Date
    Sep 2001
    Location
    Redondo Beach, CA
    Posts
    7,324
    Originally posted here by neolithium

    more bother... linux is such a pain. Now I know its wrong to defend windose but windows never has this problem. neither does it have ANY of these problems I have with linux. Or maybe RED HAT SUX!!!. I remember when I had suse, now those were the good days. I was online the same day and everything worked. But it was a live-eval. lol. If anyone knows an ftp or something where I can get the suse iso's for ummm, 8.2 i think i'd be very greatful.
    (Vodka on IRC?).

    It's not wrong to defend windows however you are comparing apples to oranges. Yes both are fruit but they taste so different it really doesn't make sense to do the comparison. On windows, they hide a lot of what you need to do. In addition, everything needs to be "pre-compiled" before you install things. With Linux you have the ability to alter any program you want to install (for the most part -- aka 99.999%). I know you are coming from a windows background but you do need to let go of what you understand from there to a degree. As I mentioned to do there is a difference between those that understand and those that just do. Those that understand learn how to trouble shoot, go with the flow and can pretty much find a solution to any problem. Those that just do poke and prod. If it doesn't work, oh well give up. I think you are in the first category. You've come this far.

    A little research using the power of Google can go a long way.

    NTFS -- http://linux-ntfs.sourceforge.net/ (Heck, I didn't even know it's now a simple RPM install until I did the search for you).

    Now, as for Red Hat.. ya. It's extremely likely they are sucking with version 9. You could check to see if anyone has Suse 8.2 and can burn it (I don't use SUSE so sorry, I can't help that way) but I wonder if that will open other problems.

    You may also want to check into LUGs in your area (Linux User Groups) as well as Magazines and other sites. Rather than saying it sucks or it's horrible, get to understand what's going on. I suspect that your understanding of hardware, operating systems and networks will go up expontentially.
    Goodbye, Mittens (1992-2008). My pillow will be cold without your purring beside my head
    Extra! Extra! Get your FREE copy of Insight Newsletter||MsMittens' HomePage

  9. #19
    Senior Member
    Join Date
    Oct 2001
    Posts
    385
    for the nVidia drivers:

    1: did you completely exit X?

    2: they do not install immediately, give it a minute or two (or more if you have a slower machine).

    If you've done both, I'm not quite sure. They installed perfectly into RH9 on both my athlon and pentium using the sh <filename> command.
    Preliminary operational tests were inconclusive (the dang thing blew up)

    \"Ask not what the kernel can do for you, ask what you can do for the kernel!\"

  10. #20
    Junior Member
    Join Date
    May 2003
    Posts
    25
    I boot winxp and red hat 8. I recently switched to cable (and can't get the cable to work) but I had dsl before with alcatel usb speedtouch. I tried all 3 drivers mentioned above and never did get the thing to work. Just thought I would let you know you're not alone. Man I can do anything with windows. I know it inside and out but I started on linux about 6 months ago (on and off) and it boggles me too. Just so different. It's kind of like leaving a game your really good at to start a new one you can't even play. Just feels awkward and clumsy.

    Anyway...... keep trying and I am sure it will pay off. To many people like linux for it not to be great.
    Hi, I don\'t care........ Thanks

    4sale

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 Security News

     Patches

       Security Trends

         How-To

           Buying Guides