redhat 8 won't let me change my clock time
Results 1 to 3 of 3

Thread: redhat 8 won't let me change my clock time

  1. #1
    Senior Member
    Join Date
    Aug 2001

    Angry redhat 8 won't let me change my clock time

    ive had redhat 8 as my 'server' system for about a year now and i moved the time forward an hour for daylight saving here in aus, now it refuses to let me change it back at all, no in root user or any other user, on the other account it prompts me for the root pass which i give it, on the root account nothing hapens at all, there is a bit of disk activity like it is trying to load the config but nothing shows up and its stuck an hour too fast, i know its not system critical but its just annoying

    ive tried through the shortcut on the taskbar, with all my accounts and also through the 'menu' in system settings i think it is

    please help me get my time right pls

  2. #2
    Leftie Linux Lover the_JinX's Avatar
    Join Date
    Nov 2001
    Beverwijk Netherlands
    mine updates via a ntpdate server..

    but you should be able to set the clock with the date command..

    DATE(1)                          User Commands                         DATE(1)
           date - print or set the system date and time
           date [OPTION]... [+FORMAT]
           date [-u|--utc|--universal] [MMDDhhmm[[CC]YY][.ss]]
           Display the current time in the given FORMAT, or set the system date.
           -d, --date=STRING
                  display time described by STRING, not `now'
           -f, --file=DATEFILE
                  like --date once for each line of DATEFILE
           -ITIMESPEC, --iso-8601[=TIMESPEC]
                  output  date/time  in ISO 8601 format.  TIMESPEC=`date' for date
                  only, `hours', `minutes', or `seconds' for date and time to  the
                  indicated  precision.   --iso-8601  without TIMESPEC defaults to
           -r, --reference=FILE
                  display the last modification time of FILE
           -R, --rfc-822
                  output RFC-822 compliant date string
           -s, --set=STRING
                  set time described by STRING
           -u, --utc, --universal
                  print or set Coordinated Universal Time
           --help display this help and exit
                  output version information and exit
           FORMAT controls the output.  The only valid option for the second  form
           specifies Coordinated Universal Time.  Interpreted sequences are:
           %%     a literal %
           %a     locale's abbreviated weekday name (Sun..Sat)
           %A     locale's full weekday name, variable length (Sunday..Saturday)
           %b     locale's abbreviated month name (Jan..Dec)
           %B     locale's full month name, variable length (January..December)
           %c     locale's date and time (Sat Nov 04 12:02:33 EST 1989)
           %C     century  (year  divided  by  100  and  truncated  to an integer)
           %d     day of month (01..31)
           %D     date (mm/dd/yy)
           %e     day of month, blank padded ( 1..31)
           %F     same as %Y-%m-%d
           %g     the 2-digit year corresponding to the %V week number
           %G     the 4-digit year corresponding to the %V week number
           %h     same as %b
           %H     hour (00..23)
           %I     hour (01..12)
           %j     day of year (001..366)
           %k     hour ( 0..23)
           %l     hour ( 1..12)
           %m     month (01..12)
           %M     minute (00..59)
           %n     a newline
           %N     nanoseconds (000000000..999999999)
           %p     locale's upper case AM or PM indicator (blank in many locales)
           %P     locale's lower case am or pm indicator (blank in many locales)
           %r     time, 12-hour (hh:mm:ss [AP]M)
           %R     time, 24-hour (hh:mm)
           %s     seconds since `00:00:00 1970-01-01 UTC' (a GNU extension)
           %S     second (00..60)
           %t     a horizontal tab
           %T     time, 24-hour (hh:mm:ss)
           %u     day of week (1..7);  1 represents Monday
           %U     week number of year with Sunday as first day of week (00..53)
           %V     week number of year with Monday as first day of week (01..53)
           %w     day of week (0..6);  0 represents Sunday
           %W     week number of year with Monday as first day of week (00..53)
           %x     locale's date representation (mm/dd/yy)
           %X     locale's time representation (%H:%M:%S)
           %y     last two digits of year (00..99)
           %Y     year (1970...)
           %z     RFC-822 style numeric timezone (-0500) (a nonstandard extension)
           %Z     time  zone  (e.g.,  EDT),  or  nothing if no time zone is deter-
           By default, date pads numeric fields with zeroes.  GNU date  recognizes
           the following modifiers between `%' and a numeric directive.
                  `-' (hyphen) do not pad the field `_' (underscore) pad the field
                  with spaces
           Written by David MacKenzie.
           Report bugs to <>.
           Copyright (C) 2002 Free Software Foundation, Inc.
           This is free software; see the source for copying conditions.  There is
           NO  warranty;  not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
           The full documentation for date is maintained as a Texinfo manual.   If
           the  info  and  date  programs are properly installed at your site, the
                  info date
           should give you access to the complete manual.
    date (sh-utils) 2.0.15            August 2002                          DATE(1)
    in short:

    Setting the system clock
    To set the system clock under Linux, use the date command. As an example, to set the current time and date to July 31, 11:16pm, type ``date 07312316'' (note that the time is given in 24 hour notation). If you wanted to change the year as well, you could type ``date 073123161998''. To set the seconds as well, type ``date 07312316.30'' or ``date 073123161998.30''. To see what Linux thinks the current local time is, run date with no arguments.

    Setting the hardware clock
    To set the hardware clock, my favourite way is to set the system clock first, and then set the hardware clock to the current system clock by typing ``/sbin/hwclock --systohc'' (or ``/sbin/hwclock --systohc --utc'' if you are keeping the hardware clock in UTC). To see what the hardware clock is currently set to, run hwclock with no arguments. If the hardware clock is in UTC and you want to see the local equivalent, type ``/sbin/hwclock --utc''
    ASCII stupid question, get a stupid ANSI.
    When in Russia, pet a PETSCII.

    Get your ass over to SLAYRadio the best station for C64 Remixes !

  3. #3
    Senior Member
    Join Date
    Jan 2002
    As long as you aren't dual booting with a lame OS then you won't need to manually adjust for daylight saving - the Linux timezone should take care of that.

    If you *are* dual booting with a lame OS, you have bigger problems - I normally keep the lame OS in GMT (of course closer here in the UK) and let Linux worry about daylight saving.

    Some Lame OSs seem to have the stupid idea of storing the time in the hardware clock in local time with daylight savings. This is a fantastically bad thing to do, because it means they have to adjust the hardware clock twice a year, but have no way of telling other OSs (even by the same vendor) on the same machine that they've done that, meaning that they cannot possibly get it right in the long term.

    All systems which are vaguely sensible keep the hardware clock in UTC. Or at least the same timezone all year.


    As for your problem - Presumably Redhat's KDE desktop or whatever just doesn't work properly, just adjust it from the command line with the "date" command (read the man page).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts