A new vulnerability has been discovered with version 4.0 of the Microsoft JET Database engine - the vulnerability is a buffer overflow affecting SQL Server 2K, SQL Server 7, and MSDE. This can possibly affect a number of people if they are using this version of the JET engine for database access. The advisory is available here:


Service Pack 7 for the JET DE is supposed to be the fix for this overflow - the service pack is available from Microsoft.