I have a bit of a problem. I was upgrading my cisco IOS the other night to fix a problem with my mail client not authenticating properly... and to just get the newest IOS.

I DO have console access and it is my router... The router is a Cisco 806 broadband router.

After uploading my new IOS, I reloaded it like you normally would... this is what I get...

System Bootstrap, Version 12.2(4r)XM3, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2002 by cisco Systems, Inc.
C800/SOHO series (Board ID: 17-100) platform with 32768 Kbytes of main memory

program load complete, entry point: 0x80013000, size: 0x4c589c

Error : compressed image checksum is incorrect 0x7CAF0C71
ž Expected a checksum of 0x7CAF0C9E
*** System received a Software forced crash ***
signal= 0x17, code= 0x5, context= 0x0
PC = 0xbaddaddd, Vector = 0xbaddaddd, SP = 0xbaddaddd
I tried to upgrade it to c806-o3sy6-mz.123-2.T.bin from c806-o3sy6-mz.122-4.YH.bin
Everytime I reboot it... I get that message so I can't get to CLI to erase flash to load a different IOS image...

Here is what I have tired so far...

Using the process here I have gotten into ROMMON to change the registers...

Press Break on the terminal keyboard within 60 seconds of the power-up to put the router into ROMMON.

If the break sequence doesn't work, see Possible Key Combinations for Break Sequence During Password Recovery for other key combinations.

Type confreg 0x2142 at the rommon 1> prompt to boot from Flash without loading the configuration.

Type reset at the rommon 2> prompt.

The router reboots but ignores its saved configuration.
Since I can get to ROMMON I can change the registers...

Configuration Registers

The global configuration command - config-register is used to modify the behaviour of the router. Weather or not it boots from saved configuration. Weather or not it boots from the flash or the boot-proms.

The following page is an excellent reference for configuration registers http://www.cisco.com/univercd/cc/td/...ig/vconfig.htm

In summary these Boot Registers are quite handy:

The value range is from 0x0 to 0xFFFF.
0x2102 is the factory-default configuration register value.
0x2142 boots from flash without using NVRAM contents good for password recovery.
0x2101 boots from boot prom image not flash, good for upgrading image on flash.
0x2141 boots from boot prom and ignores NVRAM contents.
0x141, which disables the Break key, ignores the NVRAM configuration, and
boots the default system image from ROM.
Source

I have tried ALL of these registers.. and I can't get to CLI.
Everything I have tried still results in the message that is in my first quote.

I have just seen the boot helper image.. and am going to mess with that for a bit.

Configuring the Boot Field
The lowest four bits of the processor configuration register (bits 3, 2, 1, and 0) form the boot field. (See Table D-2.)

Table D-2 Explanation of Boot Field (Configuration Register Bits 00-03)

Boot Field Meaning
00
Stays at the system bootstrap prompt (ROM monitor) on a reload or power cycle

01
Boots the boot helper image as a system image

02-F
Specifies a default netboot filename

Enables default booting from system Flash memory

Enables boot system commands that override the default netboot filename1

1Values of the boot field are 2-15 in the form cisco<n>-processor_name, where 2 < n < 15.

The boot field specifies a number in binary. If you set the boot field value to 0, you must have console port access to boot the operating system manually. Boot the operating system manually by entering the b command at the bootstrap prompt as follows:

> b [tftp] flash filename
Definitions of the various command options follow:

b—Boots the default system software from ROM
b flash—Boots the first file in Flash memory
b filename [host]—Boots over the network using TFTP
b flash [filename]—Boots the file (filename) from Flash memory
For more information about the b [tftp] flash filename command, see the appropriate Cisco IOS software publications.

If you set the boot field value to a value of 2 through F, and there is a valid system boot command stored in the configuration file, the router boots the system software as directed by that value. (See Table D-3.) If you set the boot field to any other bit pattern, the router uses the resulting number to form a default boot filename for booting from a network (TFTP) server.

If there are no boot commands in the configuration file, the router attempts to boot the first file in system Flash memory. If no file is found in system Flash memory, the router attempts to netboot a default file whose name is derived from the value of the boot field (for example: cisco2-4500). If the attempt to boot from a network (TFTP) server fails, the boot helper image in boot Flash will boot up.

If boot commands are in the configuration file, the router software processes each boot command in sequence until the process is successful or the end of the list is reached. If the end of the list is reached without a file being successfully booted, the router will retry the netboot commands up to six times unless the boot default ROM software if netboot fails bit (bit 13 of the virtual configuration register) is set. If bit 13 is set, the system boots the boot helper image found in boot Flash memory without any retries.

In the following example, the virtual configuration register is set to boot the router automatically from Flash memory and to ignore Break at the next reboot of the router
Mybe I'm missing something here... but how do I change the boot register to get the boot helper image instead of the sysem image stored in flash?! Will I be able to delete the other image in flash from the boot helper?
http://www.cisco.com/univercd/cc/td/...ig/vconfig.htm
Can Someone help me understand?

When I change confreg 00 or 0x00 or what? will that leave me at bootstrap where I can try to load a system image from a tftp server? I have other system images I know that works... I just need to load it to flash...

Configuration Register
The virtual configuration register is in nonvolatile RAM (NVRAM) and has the same functionality as other Cisco routers. You can view or modify the virtual configuration register from either the ROM monitor or the operating system software. Within ROM monitor, you can change the configuration register by entering the register value in hexadecimal format, or by allowing the ROM monitor to prompt you for the setting of each bit.

Changing the Configuration Register Manually
To change the virtual configuration register from the ROM monitor manually, enter the command confreg followed by the new value of the register in hexadecimal, as shown in the following example:

rommon 1 > confreg 0x2101

You must reset or power cycle for new config to take effect
rommon 2 >

The value is always interpreted as hexadecimal. The new virtual configuration register value is written into NVRAM but does not take effect until you reset or reboot the router.

Changing the Configuration Register Using Prompts
Entering confreg without an argument displays the contents of the virtual configuration register and a prompt to alter the contents by describing the meaning of each bit.

In either case, the new virtual configuration register value is written into NVRAM but does not take effect until you reset or reboot the router.

The following display shows an example of entering the confreg command:

rommon 7> confreg

Configuration Summary
enabled are:
console baud: 9600
boot: the ROM Monitor

do you wish to change the configuration? y/n [n]: y
enable "diagnostic mode"? y/n [n]: y
enable "use net in IP bcast address"? y/n [n]:
enable "load rom after netboot fails"? y/n [n]:
enable "use all zero broadcast"? y/n [n]:
enable "break/abort has effect"? y/n [n]:
enable "ignore system config info"? y/n [n]:
change console baud rate? y/n [n]: y
enter rate: 0 = 9600, 1 = 4800, 2 = 1200, 3 = 2400 [0]: 0
change the boot characteristics? y/n [n]: y
enter to boot:
0 = ROM Monitor
1 = the boot helper image
2-15 = boot system
[0]: 0

Configuration Summary
enabled are:
diagnostic mode
console baud: 9600
boot: the ROM Monitor

do you wish to change the configuration? y/n [n]:

You must reset or power cycle for new config to take effect
Source

Then I'd need to xfer via console since I won't have any ip set to my LAN ethernet interface?

I called cisco support and they told me that I'd have to open a TAC in which I'd need a contract (which I don't have)... etc. etc.

Is there any way I can resolve my problem? I'm not a cisco newbie... I just don't use them all that much and they don't teach us that kind of stuff in class... just the basic config... not how to bring one back to life... I have already messed it all up and I'm a little nervous of changing too much stuff and I won't be able to do anything at all!!!

I'll be on vacation thurs night (7/31) through tues night (8/5) so if I don't reply between that time... its because I don't have access to a PC...

Thank you Thank you Thank you Thank you Thank you to anyone who does reply.