Hey all,

Recently, I was fortunate to install Red Hat Linux 9 on my system, and with the help of my fellow AOers, configure my X Windows system correctly.

Now i'm on to my next task: configuring my wireless connection.

I have a D-Link DWL-120+, and have been mildly successful in finding the linux drivers for it, since D-Link doesn't offer them. I found them here:

http://atmelwlandriver.sourceforge.net/downloads.html

I dowloaded the bzipped and rebooted in linux. I mounted the cd-rom, and began the task of
installing the drivers. I extracted the files to /usr/local/bin/atmelwlandriver.

As instructed by the README, I ran 'make config' at a bash shell.
  • Build all? y/N y
    Set extra module version information? y/N y

    X Windows include files missing
    Kernel Version Running 2.4.20-8
    Found Kernel SOurce Directory ()
    grep: /.configure: no such file or directory
    /scripts/setup.sh line 96: [: -eq: unary operator expected]

    root dir of external pcmia:

What do I input there? What directory is it talking about, because I usually just put where I unzipped it.

After I enter the directory (which is proabably wrong) I get this...
  • pcmia.(the dir I put)...does not exist
    Finished. Now run make clean, all, install

I run 'make clean' and it comes out OK, but the problems start happening when I run 'make all.' It comes up with a huge amount of errors, like parse errors, no such file errors, etc.
'make install' comes up with
  • set -x
    depmod -aq
    OK

and thats it.... I check under ifconfig and it still doesn't show the media, neither does it show under the "Network Hardware" panel.

What am I doing wrong? I'm a huge *nix newb, remember.

Thanks