Linux Networking.
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Linux Networking.

  1. #1
    Junior Member
    Join Date
    Aug 2003
    Posts
    13

    Linux Networking.

    I installed RedHat 7.1 on 2 of my computers and set them both up for networking. Their ip's are 192.168.0.3 and 192.168.0.4 . When I boot both machines up it starts everything fine but when I try to ping the machines it says 'host not reachable'. The activity light on the machine's NIC lights up but it still gives me the 'hot not reachable message'.Can someone please tell me why this is happening? I would greatly appreciate it.

    -libertie

  2. #2
    Senior Member
    Join Date
    May 2002
    Posts
    450
    Check and make sure you entered the machines respective IP's in the /etc/hosts.allow file, so they are allowed to access each other.

    Example on machine 192.168.0.3 /etc/hosts.allow should have something like this

    ALL: 192.168.0.4

    This should give 192.168.0.4 full access to the machine .... read up a bit and you can limit the access to each machine through this file ... i.e just ftp access or whatever you nominate.

    Good luck, hope this helps.

  3. #3
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003
    Posts
    992
    what do you get when trying ifconfig in the shell ?

    It could be only your loopback would be active. The only one in his routing table then would be 127.0.0.1 = localhost = himself. Check if you see something like eth0 ....

    If you don't see this , you might wanna check if your nic is loaded properly. To do this you can type :
    dmesg | grep eth

    You can always give the output here...

    Good luck
    Come and check out our wargame-site @ http://www.rootcontest.org
    We chat @ irc.smdc-network.org #lobby

  4. #4
    Senior Member
    Join Date
    Jan 2002
    Posts
    1,207
    Originally posted here by Phat_Penguin
    Check and make sure you entered the machines respective IP's in the /etc/hosts.allow file, so they are allowed to access each other.
    No, don't.

    Being in or out of hosts.allow has no impact whatsoever on the ability to ping machines.

    hosts.allow only affects a few services.

    Slarty

  5. #5
    Member
    Join Date
    May 2003
    Posts
    42
    I think this is not the right place to post this question, but nyways:

    I had the same problem and posted it under *nix.

    I had the same problem with RH7.1 and also caldera 2.4.

    I dint get any replys , so i will be intrested in following this

    Cheers
    antisecurityboy

  6. #6
    Junior Member
    Join Date
    Aug 2003
    Posts
    13
    When I type ifconfig I get my loopback stuff and i get eth0. It is frustrating b/c when I ping from 192.168.0.3 to 192.169.0.4 the activity light comes on both and the hub blinks and shows activity.Thanks for the help Phat_Penguin but I think slarty is right. All hosts were allowed by default. Right? Another thing-when I turn one of the computers on the activity light automaticly turns green on the hub, even before networking starts up. On the second it only comes on when networking starts. Would this have any effect or cause a problem? It is another question that has plagued me.
    Here you go Shrekkie-
    eth0: 3c509 at 0x220, 10baseT port, address 00 00 76 2a 6f 02, IRQ 11.
    eth1: 3c509 at 0x300, 10baseT port, address 00 04 76 2f 6f 46, IRQ 10.
    eth0: Setting Rx mode to 1 addresses.

    -libertie

  7. #7
    Trumpet-Eared Gentoo Freak
    Join Date
    Jan 2003
    Posts
    992
    Is this the output of one box ? If so why are there two nics in one box ? firewall or sumtin ?

    Are they both connecting to each other through a hub ? If so try connecting the boxes with a crosscable directly and then try again.
    Another problem between NIC - HUB - NIC could be the speed both nics and the hub work with. Normally they should be able to autosense and negotiate with eqach other, but if the nics are on 10BaseT and the Hub ( for example) 100BaseT they won't see each other.
    Come and check out our wargame-site @ http://www.rootcontest.org
    We chat @ irc.smdc-network.org #lobby

  8. #8
    Senior Member
    Join Date
    Jul 2001
    Posts
    461
    can you post a everything you get from running ifconfig on each machine?

  9. #9
    Junior Member
    Join Date
    Sep 2003
    Posts
    1

    Angry nic issues in linux

    It would be best if you posted your ifconfig and your startup config files so that we can see what you've done and why the route is not working. I haven't used Linux in awhile (I use FreeBSD) but it seems to me you need to set the ip addys for each machine in a resolve file (/etc/resolv.conf in BSD). Also, its easier for all to diagnose your problems if we can see all the config files you've added NIC info to.

    Originally posted here by slarty


    No, don't.

    Being in or out of hosts.allow has no impact whatsoever on the ability to ping machines.

    hosts.allow only affects a few services.

    Slarty
    Reminder: hosts.allow and hosts.deny are for security purposes.

  10. #10
    Senior Member Maestr0's Avatar
    Join Date
    May 2003
    Posts
    604
    AFAIK hosts.* is only for services that are using tcp_wrappers(tcpd).

    -Maestr0
    \"If computers are to become smart enough to design their own successors, initiating a process that will lead to God-like omniscience after a number of ever swifter passages from one generation of computers to the next, someone is going to have to write the software that gets the process going, and humans have given absolutely no evidence of being able to write such software.\" -Jaron Lanier

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •